Issue 32322 - customize dialog unusable in m47 at 800x600 resolution
Summary: customize dialog unusable in m47 at 800x600 resolution
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 680m47
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: atr
QA Contact: issues@sw
URL:
Keywords: oooqa, regression
Depends on:
Blocks:
 
Reported: 2004-07-30 02:52 UTC by bulbul
Modified: 2013-08-07 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot of 1.9m47 customize dialog at resolution of 800x600 (23.50 KB, image/png)
2004-07-30 02:54 UTC, bulbul
no flags Details
configuration dialog as it looked in OOo 1.1.1 at 800x600 (48.75 KB, image/png)
2004-07-30 02:55 UTC, bulbul
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bulbul 2004-07-30 02:52:44 UTC
The customize dialog in m47 is unusable in Linux at a screen resolution of
800x600. It is way too long, leaving no way (in KDE) to get to the buttons at
the bottom of the dialog. I will attach screenshots.
Comment 1 bulbul 2004-07-30 02:54:38 UTC
Created attachment 16853 [details]
screenshot of 1.9m47 customize dialog at resolution of 800x600
Comment 2 bulbul 2004-07-30 02:55:40 UTC
Created attachment 16854 [details]
configuration dialog as it looked in OOo 1.1.1 at 800x600
Comment 3 bulbul 2004-07-30 02:57:04 UTC
Adding "regression" keyword, as this worked in OOo 1.1.1, as the second
screenshot shows.
Comment 4 michael.ruess 2004-07-30 07:03:21 UTC
reassigned to ES.
Comment 5 bulbul 2004-07-30 14:43:52 UTC
Is there no chance of OOo 2.0 here? This bug seriously cripples OOo at 800x600,
which is a common screen resolution. There is no way for the user to access the
functionality of the customize dialog at this resolution.
Comment 6 eric.savary 2004-07-30 15:51:23 UTC
Not sure we can get it for the 2.0 but we can try.
workaround: on unix you can move dialog without clicking the title bar, just
using Alt+click anywhere in the dialog.

->CJ: We still support 800x600 so we have to find a solution for this.
Comment 7 bulbul 2004-07-30 16:17:04 UTC
Thanks for telling me about the Alt+click function. Unfortunately, this doesn't
work as a workaround for this bug. If you move the dialog up, the dialog is
still sized in its truncated form and there's no way to pull the bottom to get
the widgets at the bottom to appear.
Comment 8 lohmaier 2004-07-30 22:39:55 UTC
This must be KDE-specific/related to the theme used. When running with gnome,
the customize screen fits in 800x600 (it's 553x518) with all the buttons
available...

Especially cutting-off the dialog seems to be a problem of the window manager.
To make it short: I cannot reproduce.
Comment 9 bulbul 2004-07-30 23:15:10 UTC
I can confirm that i can reproduce this bug under KDE but not under Gnome on the
same machine.
Comment 10 christian.jansen 2004-08-02 08:17:05 UTC
Since OpenOffice 1.1 our min. requiered resolution 1024x768 so we are in the
range .  A tip what might help. Go to tools/options/openoffice/view. and scale
the size of the dialogs.
Comment 11 christian.jansen 2004-08-02 08:17:35 UTC
.
Comment 12 christian.jansen 2004-08-02 08:18:09 UTC
.
Comment 13 bulbul 2004-08-04 06:49:49 UTC
The system requirements pages for both OOo 1,1 and StarOffice 7 both say that
the minimum screen resolution is 800x600, for all platforms:

<http://www.openoffice.org/product/reqts.html>
<http://wwws.sun.com/software/star/staroffice/requirements.html>

The Linux README file for OOo 1.9 also says 800x600.

I am reopening on the basis of these pages. If this information is incorrect,
please point to where the correct system requirements can be found. I have spent
an hour searching the OOo site for the 1024x768 mentioned, but found it only in
one document in Japanese. Everywhere else says that the requirement is 800x600.
Comment 14 christian.jansen 2004-08-04 07:40:43 UTC
Sorry for giving you the wrong information that oo.o 1.1 requieres 1024x768, but
oo.o does. The documents will be updated soon. I'll take this take issue for
changing the README.
CJ->dedr: Could you please update the README. Thanks.
Comment 15 bulbul 2004-08-04 08:37:39 UTC
> the wrong information that oo.o 1.1 requieres 1024x768, but
> oo.o does.

Did you mean "but oo.o 2.0 does"? Was this discussed on one of the mailing lists?

By the way, the tools/options/openoffice/view rescaling tip *almost* works. If i
get rid of my toolbar, i can get almost the whole dialog, but not the text on
the bottom buttons. It's usable if i remember what those four buttons at the
bottom are.

Comment 16 derekd 2004-10-25 11:42:07 UTC
Accepted
Comment 17 frank.thomas.peters 2004-11-24 14:27:21 UTC
FPE: Please verify in readme680beta
Comment 18 frank.thomas.peters 2004-11-24 14:27:38 UTC
.
Comment 19 atr 2004-11-25 08:12:38 UTC
ATR: verified in readme680beta, fixed.
Comment 20 atr 2004-12-03 11:11:11 UTC
ATR: checked again in master build m64, fixed.