Issue 32327 - Default bullet symbol not displayed correctly (Win98)
Summary: Default bullet symbol not displayed correctly (Win98)
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 680m49
Hardware: All Windows 98
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
: 36140 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-07-30 08:12 UTC by michael.ruess
Modified: 2013-08-07 14:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description michael.ruess 2004-07-30 08:12:22 UTC
When opening the Format.Numbering dialog, tabpage "Bullets", the first Bullet is
displayed incorrectly. This also applies to the document view, when the bullet
is assigned to the paragraph.
Due to the fact, that this is also the default bullet symbol when applying a
bullet by using the toolbar icon "Bullets on/off", this is quite important.
Daoes not happen with StarSymbol font, only OpenSymbol.
Comment 1 lohmaier 2004-07-30 18:45:05 UTC
this is (probably) duplicate to longstanding issue 19105

If you close this one as duplicate, please make sure issue 19105 will get the
necessary attention. You may as well keep one issue open for OOo 2.0 while
keeping the other for OOo 1.1.x
Comment 2 hdu@apache.org 2004-08-24 17:00:06 UTC
Works fine when the StarSymbol font is installed, so I guess either the
OpenSymbol font is too incomplete or the Writer shouldn't default to symbols not
available in OpenSymbol... Still analyzing
Comment 3 hdu@apache.org 2004-10-19 13:02:15 UTC
HDU->OS: I just analyzed it and the problem is that StarSymbol only bullets are
used in this tabpage. We should choose only symbols that are also available in
OpenSymbol. Is it correct that these symbols are selected in the aBulletTypes[]
array in svx/source/dialog/svxbmpnumvalueset.cxx? We should also check other
locations where symbols from StarSymbol/OpenSymbol are involved.

I suggest to replace U+E00C with U+2666 and U+E00A with U+25A0. There are little
differences in their metrics though.
Comment 4 Oliver Specht 2004-10-25 08:50:25 UTC
os->fl: Any objections to changes these symbols? 
Since num0201 will not be integrated this should be added to the related spec, too.
Comment 5 hdu@apache.org 2004-11-05 13:21:27 UTC
*** Issue 36140 has been marked as a duplicate of this issue. ***
Comment 6 frank.loehmann 2004-11-30 16:07:21 UTC
FL->hbrinkm: Is it possible to integrate the changes already made in the not yet
integrated num02 workspace regarding the new default bullet size?
Comment 7 okapi1253 2004-12-15 06:35:12 UTC
The bullet graphic is now showing for me in XP in 1.9.65 for default bullet.
Comment 8 openoffice 2005-02-03 16:21:41 UTC
/cvs/sw/sw/inc/numrule.hxx,v  <--  numrule.hxx                                  
new revision: 1.21.114.1; previous revision: 1.21                               
/cvs/sw/sw/source/core/doc/number.cxx,v  <--  number.cxx
new revision: 1.26.102.1; previous revision: 1.26
/cvs/sw/sw/source/ui/wrtsh/wrtsh1.cxx,v  <--  wrtsh1.cxx
new revision: 1.42.2.1; previous revision: 1.42
Comment 9 openoffice 2005-02-04 10:41:59 UTC
accepted
Comment 10 openoffice 2005-02-04 11:12:02 UTC
fixed: adapted the code for the new bullets from num0201

/cvs/sw/sw/source/core/doc/number.cxx,v  <--  number.cxx
new revision: 1.26.102.2; previous revision: 1.26.102.1
Comment 11 andreas.martens 2005-02-10 10:14:08 UTC
*** Issue 42357 has been marked as a duplicate of this issue. ***
Comment 12 openoffice 2005-02-14 12:57:02 UTC
ready for QA
re-open issue and try to reassign to mru@openoffice.org
Comment 13 openoffice 2005-02-14 12:57:06 UTC
try to reassign to mru@openoffice.org
Comment 14 openoffice 2005-02-14 12:57:25 UTC
try to reset resolution to FIXED
Comment 15 michael.ruess 2005-02-18 15:04:09 UTC
Verified fix in CWS swqcore06. Remaining problem regarding dialog is tracked as
issue 43084.
Comment 16 michael.ruess 2005-06-15 11:11:22 UTC
Closed.