Issue 32446 - Fix to make software simpler and remove a common misunderstanding by Windows users
Summary: Fix to make software simpler and remove a common misunderstanding by Windows ...
Status: CLOSED FIXED
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1.2
Hardware: All All
: P3 Trivial with 18 votes (vote)
Target Milestone: AOO PleaseHelp
Assignee: frank.loehmann
QA Contact: issues@ui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-02 14:42 UTC by jimmyh
Modified: 2017-05-20 09:26 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jimmyh 2004-08-02 14:42:04 UTC
On the users@openoffice.org list we very often get emails (every couple of 
days) from Windows users saying things like: 
 
"Since I installed OpenOffice I can't use Word/Works" (because when they 
double click a word doc they are now taken into OO) 
" have recently Downloaded The OPEN OFFICE PROGRAM and in consequence it has 
totally corrupted my Microsoft Office program" 
"Why has your software deleted Word from my computer?" (same reason) 
"When I installed OO it converted all my documents to your format" (because 
different icons are used) 
 
Currently the installer asks the user if they want to associate MSO filetypes 
with OO, but it is evident a lot of people don't understand this and it has 
come up so many times that I think it has to be dealt with. 
 
The best way I can see is if the installer detects MS Office/Works on the 
computer it associates a tiny launcher program with their formats. All this 
launcher does is ask the user if they would like to open the file in MSO or 
OO, and then launch the selected program. There'd also be an option not to ask 
again, to stop the launcher being too annoying. 
 
I think this would be a lot easier for non-technical users to understand. 
Asking someone about how to configure file associations gives them a lot more 
opportunity to misunderstand than the much simpler question "You just double 
clicked a Word'97 document, do you want to open it in MSO or OO?" 
 
In a rough ascii art representation , it'd look something like this: 
 
/---------------------------------------------------------------------\ 
| Open File in...						   .x | 
----------------------------------------------------------------------| 
| You just clicked to open the Microsoft Word XP file somefile.doc,   | 
| do you wish to open it in:                                          | 
|                                                                     | 
|	(*) OpenOffice Writer                                         | 
|	( ) Microsoft Word XP                                         | 
|                                                                     | 
|	[x]Always use this choice:                                    | 
|		(*) For Word documents                                | 
|		( ) For all Microsoft Office File Formats             | 
|                                                                     | 
|                 [ Ok ] [ Cancel ]                                   | 
\---------------------------------------------------------------------/
Comment 1 nicu_ooo 2004-08-02 14:59:33 UTC
i think a more traditional approach for Windows users is to have a panel in
Tools->Options with the supported formats and checkboxes for making OOo the
default application for those types (for example like in Winamp)
is any major Windows application using this launcher method?
Comment 2 dcarrera 2004-08-02 15:13:35 UTC
*** Issue 32446 has been confirmed by votes. ***
Comment 3 jimmyh 2004-08-02 15:19:00 UTC
The problem from the users list is that a lot of Windows users don't know what  
file associations are. Therefore asking them to goto Tools->Options (I assume  
this is from windows explorer) to set them is no help at all.  
  
An example of a similar launcher is when the user inserts an audio CD or video  
DVD in WinXP. A little dialogue box comes up asking what the user would like  
to do with it.   
  
I don't know of any other apps that do it exactly this way, but then I haven't  
used Windows in a long time. Dialogs at program startup are common, and the  
launcher should be self-explanitory enough that prior experiance of exactly  
this UI element isn't necessary.  
Comment 4 stefan.baltzer 2004-08-02 17:02:52 UTC
SBA->FL: As discussed, please take over. Some notes:
(1) Unlike many other software I know, MS Office itself doesn't check the file
associations when started. So if these links are "lost" for whatever reason,
some MS Office users will be "helpless" because all they know is to double-click
in the Explorer or on an email attachment. (This could be a future MS Office
enhancement :-)
(2) OOo sets these associations back to where they were before it was installed.
But it doesn't check if these are still valid (i.e. if an old version of OOo was
removed by simply deleting it before the next one was installed)
(3) No solution ever will meet the needs of all users. First, there are those
who are well aware what's going on on their machine and thus hate every dialog
that asks them questions. On on the other "side" there are those who'd prefer
every click resulting in a dialog about what the system "guesses" they might
want in order to customize it and/or in order to learn more. Carrying further
information for each very case is again a question of "how much information is
needed to answer this question without forcing everybosdy to read a book".
Have fun :-) 
And yes, dependeing on the case there are many who are "somewhere in between"
from case to case. 
Comment 5 swisher 2004-08-02 22:43:49 UTC
I'm in favor of the proposal. However, the proposed dialog text is a little 
misleading because it suggests you could use the selected word processor for 
all MSO files, which includes non-word-processor files. Granted, it doesn't 
take much for the user to figure out the intent, but target audience for this 
message is easily confused. With a slightly better phrased text, they don't 
have to figure anything out. I propose the following changes:

(*) OpenOffice.org (Writer)
( ) Microsoft Office XP (Word)

[*] Always use the selected office suite:
    (*) For Microsoft Word documents
    ( ) For all Microsoft Office documents
Comment 6 frank.loehmann 2004-11-30 17:04:28 UTC
I am not a fan of launching dialogs after double clicking a file in the file
system at all. Think back at your own reaction i.e. in the time of  the browser
wars, when one browser had assigned itself to be the default for .html and the
other was showing a dialog with obscure questions when the application was
started or  a .html file had been double clicked. The bad app. was always the
one starting the dialog and bothering the user. So I propose to do not offer the
registration tab during setup on Windows at all, if we detect a "real" MS Office
being installed on the system and introduce a switch to force the setup to show
this page for administrators in companies.
Why should a user register OOo for his MS Office files types, when MS Office is
already installed?
Comment 7 dcarrera 2004-11-30 20:06:48 UTC
On the other hand, this dialog would appear only *once*.  And it would ensure
that the user really knows what's going to happen.

Cheers,
Daniel.
Comment 8 frank.loehmann 2004-12-22 14:40:18 UTC
set target milestone
Comment 9 frank.loehmann 2011-04-13 09:53:23 UTC
Fixed. File type association is only shown in custom setup since OOO 3.0.