Issue 32534 - compatibility problem between Open Office and the POI API to
Summary: compatibility problem between Open Office and the POI API to
Status: ACCEPTED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.1.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-03 23:20 UTC by baaann
Modified: 2013-08-07 15:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description baaann 2004-08-03 23:20:33 UTC
A file produced in OOo Calc and saved in .xls format, will not import into 
MSAccess97. The error message advises that "The wizard is unable to access 
information in the file"

The file will open fine in Excel and if then saved, imports perfectly into 
MSAccess97.

I had considered it a MSAccess bug, but another user has reported a similar 
problem with "Jakarta POI API". The report to the users list was as follows:

"We have a compatibility problem between Open Office and the POI API to 
manage Excel Files. We can't succeed to read with POI files those were 
created initially by POI and modified after with Open Office. Our Java 
application freeze when trying to execute this line:

aWorkbook = new HSSFWorkbook(new FileInputStream(aWorkBookFileName));

BUT If we modify the file with microsoft Excel and read it after with 
POI , there is no problem! And if we try to create an Excel File with 
Open Office and read it after with POI, it's working too."
Comment 1 frank 2004-08-04 09:36:34 UTC
Hi,

I tried it with a file saved by OOo1.1.2 and imported it into Access and it
worked perfectly. If a file could be read by Excel, the problem IMHO is on the
import facilitys of Acces97 wich is now 3 generations old.

As the POI problem mentioned in this Issue seems to be more relevant, I change
the summary accordingly.

Frank
Comment 2 daniel.rentz 2004-08-11 12:17:12 UTC
Accepted. Seems to be a problem of POI.