Issue 33510 - severe performance problem in Calc
Summary: severe performance problem in Calc
Status: CLOSED DUPLICATE of issue 9861
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1.2
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: niklas.nebel
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-28 11:33 UTC by panamajoe
Modified: 2013-08-07 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
this is the culprit ! (338.06 KB, application/vnd.sun.xml.calc)
2004-08-28 11:36 UTC, panamajoe
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description panamajoe 2004-08-28 11:33:31 UTC
Hi !

I have a spreadsheet which currently contains data in 11 colums by 3800 rows.
Three columns contain plain data, the other eight formulas. I am adding rows to
this on a weekly basis.

This spreadsheet currently takes 15 minutes to open !
During this time, no cpu load or heavy hard drive / memory usage is noticeable.
Saving this file takes 15 sec.
The file size is merely 350 kB.

Performance does not seem to be hardware dependant - it is the same on a Single
Athlon XP 2500+ with 512 MB RAM as on a Dual Athlon MP 2600+ with 1 GB RAM.
(or are these machines below the hardware recommendations ;-)

First, I thought this to be an Excel import issue, so I recreated this
spreadsheet in OOo Calc from scratch, which did not make a difference.

Due to this also happening with native OOo files, I classify the priority of
this issue as P1, and would heavily recommend this to be resolved for  OOo2.0 ! 
(I am not sure if this is related to issue #1905, which has been under
investigation since almost three years, and was just postponed to Release OOo
Later).

If someone could tell me how to attach a file to this issue, I'd be happy to
provide my spreadsheet for investigation !

Regards, Jochen
Comment 1 panamajoe 2004-08-28 11:36:15 UTC
Created attachment 17396 [details]
this is the culprit !
Comment 2 oc 2004-09-01 08:03:46 UTC
Hi Niklas, looks like the problem are the internet links which could not be
resolved and a very long timeout. Pressing the cancel button on the warning
message (could not establish internet connection) does not stop the whole
linking feature. This is a very enoying issue but not a P1 => P3
Comment 3 niklas.nebel 2004-09-02 14:55:43 UTC
See issue 9861.

*** This issue has been marked as a duplicate of 9861 ***
Comment 4 niklas.nebel 2004-09-02 14:56:15 UTC
closing.