Issue 33810 - Select wrong left and right table columns when resize them
Summary: Select wrong left and right table columns when resize them
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 680m51
Hardware: All Windows XP
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
: 66481 (view as issue list)
Depends on:
Reported: 2004-09-03 16:51 UTC by vyho
Modified: 2013-08-07 14:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Zip file of the document showing the bug. (1.73 KB, application/octet-stream)
2004-09-10 15:49 UTC, vyho
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description vyho 2004-09-03 16:51:08 UTC
With a table in a document.  If the left columns is small (width), select the
left border of the first column and try to resize it, when you release the
mouse, it mysteriously move the right border of the first column instead.

Same thing for the right most column.  If use mouse to grab and resize the right
border of the right table column (when the column width is small, quarter of an
inch or less), when release the mouse, the left border of this column is resized
Comment 1 michael.ruess 2004-09-06 11:46:57 UTC
I cannot reproduce the problem from the sratch, so please attach the offending
document to this issue, so that we can reproduce and fix the problem here. You
can also send the document directly ( for the case it
contains confidential data. Feel free to re-open the issue when you've done.
Thanks for supporting us!
Comment 2 vyho 2004-09-07 18:11:33 UTC
Attachment sent to
Comment 3 vyho 2004-09-10 15:49:23 UTC
Created attachment 17654 [details]
Zip file of the document showing the bug.
Comment 4 michael.ruess 2004-09-23 15:34:01 UTC
Hm, I tried with 680m54 by using your sample document, but I didn't have the
described problem. Does still occur with m54 on your machine?
If so, which screen resolution do you run? Maybe OO has a problem there...
Comment 5 vyho 2004-09-23 18:03:01 UTC
Thank you for looking into this.  It happens to 2 machines with very different
graphic cards, resolution settings and monitors (1 machine with 17 inch, the
other 21 inch, with very different resolution for each (I don't have them at
hand)).  Anyway, I can only test with m51, because I use the binary, and don't
compile with source, unless you have the binary somewhere.  I try to get it from
OpenOffice, but it still list as m51 as of now:

If you have another link, please let me know, and I'll try that.  It should be
very easy to reproduce the problem.

Comment 6 vyho 2004-09-23 23:26:06 UTC
I was able to download the m54 now (the website still show the old one, but I
just type in the address with 54 in it, and it works).  Anyway, I can easily
reproduce this problem under m54.  The screen resolution I use right now is:

1280x1024 pixels.

Try this: use the mouse to grab the leftmost edge of the table. Then drag it
slightly to the left and let go.  You'll see the problem.
Comment 7 rayll 2004-12-17 23:22:17 UTC
i can reproduce this quite easily from scratch on m65:

- file -> new -> text document
- insert -> table
  (change columns dial to 4)

now, hover the mouse over the left edge of the table until the
"adjust table column" tooltip appears. click and hold the mouse,
but do not drag yet. observe that the dotted vertical line is
perfectly aligned with the left edge of the table. drag the left
edge towards the right and release it while the first column is still
at least one inch wide.

now, you should be able to repeat this resize, but this time drag the
left edge toward the right until the first column is less than about
0.40 inches wide.

the third time you try to drag the left side of the table, click the
left side, but do not drag it.  THIS TIME, observe that the vertical
dotted line is NOT ALIGNED with the left side, but rather is placed a
few pixels to the right of the line you just clicked.

at this point, you will be dragging the second vertical line in the
table, rather than the left side which you clicked.
Comment 8 michael.ruess 2004-12-23 15:48:55 UTC
MRU->FME: now I can also see what's going on... take the attached document and
try to the left border of the table just a little bit. When having an accurate
view on the right border of the first row, you will notice that this moves a few
pixel to the right.
Comment 9 michael.ruess 2006-06-16 06:55:14 UTC
*** Issue 66481 has been marked as a duplicate of this issue. ***
Comment 10 goldenband 2007-10-11 17:41:32 UTC
I can reproduce this problem on OS X 10.4.8.  If I create a new, blank document,
and make a 20 column by 2 row table, I see behavior pretty much identical to
what's described here.
Comment 11 cno 2007-10-11 21:41:12 UTC
Sorry, but not able to reproduce with 2.3.1 and 680m231 on Win XP
Comment 12 cno 2007-10-11 21:48:43 UTC
said someone 2.3.1 ? I didn't ;-)
Must have been a phantom on the line. I only have 2.3.0 of course :-)
Comment 13 vyho 2009-10-08 03:54:45 UTC
Issue like this are not worked on, or marked as obsolete.  What's going on with
OpenOffice?  Most of my issues are left untouch after several years.  Sad!
Comment 14 cno 2009-10-08 08:13:20 UTC
@vyho: What is going on with ? Do you read Gullfoss, mail lists?
Just too few devs/QA compared to the number of wishes and bugs.
So people in the project work hard and try to improve the situation.
And alas, many issues are stalled. Energy goes to 'most important' ones and new
(BTW, with #desc9 I can reproduce, and see the little moving of the right column
border when I move the left one)