Issue 33842 - WW8: tilde in converted MathType object in wrong position
Summary: WW8: tilde in converted MathType object in wrong position
Status: CLOSED FIXED
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 1.1.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL: http://www.academ.org/~lhome/13074.doc
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-09-05 10:34 UTC by lhome
Modified: 2013-08-07 14:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
MS word doc with formulae (902.50 KB, application/msword)
2004-09-05 10:35 UTC, lhome
no flags Details
a screenshot ( bad tilde {J}, bad rSub ) (120.63 KB, image/png)
2004-09-07 13:42 UTC, lhome
no flags Details
A screenshot, how it looks with OOo-1.1.3 (123.75 KB, image/png)
2004-10-03 15:58 UTC, thackert
no flags Details
OO_1.1.2_parameters making imported formulas editable (56.32 KB, image/png)
2004-10-04 09:00 UTC, lhome
no flags Details
Much shorter document showing original problem (43.00 KB, application/msword)
2005-06-29 08:53 UTC, michael.ruess
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lhome 2004-09-05 10:34:11 UTC
Bad import of math formulae from *.doc (Word97)
Comment 1 lhome 2004-09-05 10:35:55 UTC
Created attachment 17548 [details]
MS word doc with formulae
Comment 2 thomas.lange 2004-09-06 10:30:25 UTC
TL->mmaher: There is a big performance problem when loading this bug document in
SRC680 m50.
I was told you were the right guy to have a look at loading Word documents.
Can you have a look at the problem and assing the issue back to me after that?
Thanks!
Comment 3 lhome 2004-09-07 13:26:11 UTC
I think the performance is not SO important for today. 
Of course, it will be great to have a good launch time, 
but current bad formulae conversion is a  moment that kills  
OO Writer for math editing ... 
 
I'm waiting for your further comments and ready to treat the problem  
again and again. 
 
Thanks! 
 
 
Comment 4 lhome 2004-09-07 13:42:48 UTC
Created attachment 17584 [details]
a screenshot ( bad tilde {J}, bad rSub )
Comment 5 ssarkizo 2004-09-24 03:10:27 UTC
Avgustina Sarkizova
09/23/04

I was able to reproduce the bug using OpenOffice 1.1.3. These are the steps I 
followed:

1. Download the attachment 17548 [details] and save it on the hard drive.
2. Open Windows Explorer and locate the saved file.
3. Rightclick on the file. Open With->Microsoft Word.
4. Repeat step 2.
5. Rightclick on the file. Open With->OpenOffice. (this takes several minutes.)
6. On page 2, line 26 there is a difference between the two document. 

Configuration:
Windows XP Pro
1.2 GHz AMD Athlon
376 MB
Comment 6 cbaudin 2004-09-24 04:10:01 UTC
Christian A. Baudin
September 23, 2004

I was able to replicate this bug with the same results as the above picture.  
This is my configuration and process:

Computer Specifications:

COMPUTER 1
--------------------
Intel Pentium 4 2.80 GHz CPU
1 GB RAM
Microsoft Windows 2000 (Service Pack 4)
Intel 82865G Graphics Controller
Open Office v1.1.2

COMPUTER 2
--------------------
Intel Pentium 4 2.80 GHz CPU
1 GB RAM
Fedora Core Linux Kernel 2.6.7
Intel 82865G Graphics Controller
Open Office v1.1.0

Steps:

Before beginning, I saved the given .doc attachment, that is located in a 
previous post, to my hard drive as “13074.docâ€.

1. Open a new spreadsheet.
2. From the menu bar, select Insert > Object > Formula…
3. The Formula Editor should now be open.
4. From the menu bar, select File > Open.
5. Find the file “13074.doc†and click Open.
6. Scroll down to page 11 out of 16 and compare to the previously given 
screenshot.

Note:
1) The file may take a few minutes to open.  It may also result in slow 
performance when scrolling.
2) The screenshot was not saved to my computer.  I opened the image in an IE 
browser.
Comment 7 thackert 2004-10-03 15:54:57 UTC
with OOo-1.1.3 (German version) under SuSE 9.1 it looks o.k. I will attach an
additional  screenshots to this issue. Please have a look at them, because I do
not know, if this was that, what you have intended. But I would say, that it
looks better than your screenshot.
A final note: If I try to load this document with OOo-1.9.54, OOo crashes after
a certain time of loading this file ... :(
Comment 8 thackert 2004-10-03 15:58:26 UTC
Created attachment 18090 [details]
A screenshot, how it looks with OOo-1.1.3
Comment 9 lhome 2004-10-04 08:57:20 UTC
The previous screenshot 13074.png looks fine, 
but on this screenshot, 13074.doc seems to be opened in OO with no ability 
to edit formulas. 
Please verify your OO parameters if they are set as in the attached screenshot 
OO_1.1.2_parameters.png 
 
Comment 10 lhome 2004-10-04 09:00:09 UTC
Created attachment 18104 [details]
OO_1.1.2_parameters making imported formulas editable
Comment 11 thackert 2004-10-24 17:25:08 UTC
It was the same when I have assigned these settings to OOo-1.1.3, but now I have
assigned them to OOo-1.9.56.
Comment 12 lhome 2004-10-25 09:48:35 UTC
The same what? 
Comment 13 thackert 2004-10-31 08:35:26 UTC
I mean the same parameters are marked as in your screenshot.
But I have a question: Have you tried the 1.1.3 version, if this problem occurs
there too?
Comment 14 lhome 2004-10-31 15:18:45 UTC
 
I have no 1.1.3, 
 
but there is the comment about 1.1.3 in above: 
 
------- Additional comments from ssarkizo Thu Sep 23 19:10:27 -0700 2004   
Avgustina Sarkizova 
09/23/04 
 
I was able to reproduce the bug using OpenOffice 1.1.3. These are the steps I  
followed: ... 
------------------ 
 
 
 
Comment 15 lohmaier 2004-11-01 22:39:27 UTC
The problem with the misplaced tilde is not (only) an import problem.

When you write "tilde {J} rsub M" this is the same as "tilde {J rsub M}" (or
"tilde J rsub M")

You want "{tilde J} rsub M" (the tilde still is not aligned perfectly, see issue
21486)

If this kind of error is the only one in your document, please file a new issue
and attach a word document only containing the above formula. (if similar issue
with other formattings occur, please file seperate issues for these as well).
Thank you.

This issue already grew too big to focus on the original problem (conversion
should place the brackets properly so that the result looks like expected).

I will keep this issue as "performance problem with this document". The document
crashes OOo 1.9m58. (see seperate comment)
Comment 16 lohmaier 2004-11-01 22:45:38 UTC
The attached document 13074.doc crashes OOo 1.9m58 (no crash-reporter).

To reproduce: Try to open document with OOo 1.9m58. OOo quits before displaying
the document.

terminal output:
$ openoffice1.9
terminate called after throwing an instance of 'com::sun::star::io::IOException'
sh: line 1: : command not found


Fatal exception: Signal 6
Stack:
/usr/opt/openoffice1.9.58/program/libsal.so.3[0x40c6fabc]
/usr/opt/openoffice1.9.58/program/libsal.so.3[0x40c6fbaf]
/lib/i686/libpthread.so.0[0x41232e55]
Aborted (core dumped)
$

Backtrace:
Backtrace was generated from '/opt/openoffice1.9.58/program/soffice.bin'

(no debugging symbols found)...Core was generated by
`/opt/openoffice1.9.58/program/soffice.bin'.
Program terminated with signal 6, Aborted.
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)... [more of those lines snipped]
(no debugging symbols found)...(no debugging symbols found)...#0  0x4143d3d1 in
kill ()
   from /lib/i686/libc.so.6
#0  0x4143d3d1 in kill () from /lib/i686/libc.so.6
#1  0x41232dad in raise () from /lib/i686/libpthread.so.0
#2  0x4143e979 in abort () from /lib/i686/libc.so.6
#3  0x40c6fac1 in osl_getVolumeInformation () from
/usr/opt/openoffice1.9.58/program/libsal.so.3
#4  0x40c6fbaf in osl_getVolumeInformation () from
/usr/opt/openoffice1.9.58/program/libsal.so.3

Thread 1 (process 20063):
#0  0x4143d3d1 in kill () from /lib/i686/libc.so.6
No symbol table info available.
#1  0x41232dad in raise () from /lib/i686/libpthread.so.0
No symbol table info available.
#2  0x4143e979 in abort () from /lib/i686/libc.so.6
No symbol table info available.
#3  0x40c6fac1 in osl_getVolumeInformation () from
/usr/opt/openoffice1.9.58/program/libsal.so.3
No symbol table info available.
#4  0x40c6fbaf in osl_getVolumeInformation () from
/usr/opt/openoffice1.9.58/program/libsal.so.3
No symbol table info available.
Comment 17 martin_maher 2005-05-05 10:23:26 UTC
mmaher->flr: Your's methinks
Comment 18 andreas.martens 2005-06-28 15:28:41 UTC
Document doesn't crash in so8m106.
Comment 19 andreas.martens 2005-06-28 15:35:28 UTC
Can be closed?
Comment 20 michael.ruess 2005-06-29 08:53:41 UTC
Created attachment 27556 [details]
Much shorter document showing original problem
Comment 21 michael.ruess 2005-06-29 08:59:28 UTC
No, this can -of course- NOT be closed. I have now splitted up the issue.
 - this here will handle the original problem (tilde in wrong place, see latest
attachment)
 - low performance on cenverting can now be found in issue 51338
 - above mentioned problem onpage 2 (by Avgustina Sarkizova) in issue 51339

I have changed the summary of the issue, so that the relation to the original
problem comes clear.
Comment 22 michael.ruess 2005-06-29 09:03:50 UTC
MRU->FLR: see my latest attachment. When the conversion for MathType is enabled
and the newest attachment will be opened in OO, the tilde (in the second object)
is placed differently compared to MS Word. In this case additional brackets
should be put around the  "tilde {J}" , so that the whole expression should look
like:

 size 12{ {tilde  {J}} rSub { size 8{M} }  \( Δθ \) ={}} {}
Comment 23 flr 2005-08-05 11:24:21 UTC
flr->tl: Its yours - as discussed.
Comment 24 stefan.baltzer 2005-08-05 16:24:13 UTC
SBA: I spoke to several stakeholders and did some "OOo archeology", too. This
was never working "perfectly". The issue history shows, that cloph has set the
keyword "regression" on Nov 1st 2004. 
-> Cloph, you are evil! :-) Nonono, just kidding. You were wrong. I forgive you
and simply remove the regression keyword. 
Since the crash is handled in another issue now, I removed the keyword "crash"
as well.
The keywords "crash" and "regression" shall not mess up QA queries by showing
this issue.

With issue 18211 (introduced in OOo 1.1.0) we solved the problem that formulas
from MS Word did not get converted at all. Instead, they were were kept as
graphic object, no matter what option was checked. At first glance, that may
have looked better in this case, but prevented a further editing of the formula.

So for OOo 1.1.5, ther are two workarounds:
1. Uncheck the "Math type to OOo math conversion" in  Tools - Options -
Load/Save - Microsoft Office.
2. Set the additional brackets (as mru stated above) after the document is imported.

SBA->TL: As discussed, the fix for the future (Target set to OOo 2.01 now)
should automatically set such brackets in order to disregard the indice letters
when positioning the tilde, the dot(s), the bar or whatever is on top of the
"Big characters(s)". 
Given the fact that this will affect all MS documents containing formulas, it is
too risky (and thus too much QA work to spot and avoid other "real" "bad" "ugly"
regressions in time).
Comment 25 lohmaier 2005-08-05 17:10:21 UTC
@sba: Well, you have to read my comment as well. the document did crash, and
that crash was a regression... (damn the mutating issues...)
Comment 26 Martin Hollmichel 2005-08-08 11:54:16 UTC
if the crash occurs on 1.9.58 or later we should open a new bug with target 2.0
Comment 27 thomas.lange 2005-08-08 13:31:08 UTC
.
Comment 28 thomas.lange 2005-08-08 13:34:39 UTC
Fixed in CWS tl12.

Files changed:
- mathtype.cxx  new revision: 1.32.8.2
Comment 29 thomas.lange 2005-08-22 09:31:02 UTC
.

re-open issue and reassign to mru@openoffice.org
Comment 30 thomas.lange 2005-08-22 09:31:10 UTC
reassign to mru@openoffice.org
Comment 31 thomas.lange 2005-08-22 09:31:19 UTC
reset resolution to FIXED
Comment 32 michael.ruess 2005-08-23 11:03:16 UTC
Verified fix in CWS tl12.
Comment 33 michael.ruess 2005-10-14 14:33:31 UTC
Checked fix in build 680m133.