Issue 34124 - Document from MS Word won't save as word with recorded changes.
Summary: Document from MS Word won't save as word with recorded changes.
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 1.1.2
Hardware: All Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL: http://www.cpinternet.com/~dberg/PONV...
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-13 15:56 UTC by drberg1000
Modified: 2017-05-20 11:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Shorter sample of mentioned document (55.00 KB, application/msword)
2004-09-14 09:20 UTC, michael.ruess
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drberg1000 2004-09-13 15:56:02 UTC
Here are the list of events that lead up to the problem:

Document created in OO 1.1.2 and probably saved as .sxw.  Eventually saved as
.doc (word97/2000/XP).  Doc was given to a colleague to review.  She made some
changes through the "record changes" feature.  Saved document as Word 9.0.  This
word 9.0 document is the one that I'm having problems with.  It can be found at
http://www.cpinternet.com/~dberg/PONV_paper_new-CMR.doc.  The problem is this:
when I open the word9.0 document I can see the changes and add to them and save
as .sxw, but if I try to save as word 97/200/XP ooffice segfaults.  I don't get
a core dump or I'd upload that as well.  

My system is running Debian Testing.  the ooffice package is version 1.1.2-3

Dave
Comment 1 michael.ruess 2004-09-14 09:20:36 UTC
Created attachment 17696 [details]
Shorter sample of mentioned document
Comment 2 michael.ruess 2004-09-14 09:28:44 UTC
The tracked changes are not the reason for the crash when saving this Word
document with OO Writer. The table at the end of the document makes trouble to
Writer. 

MRU->MM: there seems to be a problem with the im-/export of the complex table.
The table structure is not imported correctly; this seems to be the reason for
the crahs when saving in WW format.
Comment 3 andreas.martens 2004-12-03 08:47:46 UTC
Changed prio to 4
Comment 4 martin_maher 2005-02-22 14:06:09 UTC
mmaher: reassigning to flr. I am no longer responsible for filters.
Comment 5 andreas.martens 2005-04-01 15:41:19 UTC
Changed target.
Comment 6 stp 2005-04-20 17:28:48 UTC
WFM in development version 1.9m94. drberg1000 Please try with development
version of 2.0.
Comment 7 Mathias_Bauer 2006-08-30 15:29:53 UTC
assigning to hbrinkm
Comment 8 Marcus 2017-05-20 11:24:35 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 9 Marcus 2017-05-20 11:25:57 UTC
Reset assigne to the default "issues@openoffice.apache.org".