Issue 34698 - Importing a WORD document OOo inserts "linefeeds" in lists
Summary: Importing a WORD document OOo inserts "linefeeds" in lists
Status: CLOSED DUPLICATE of issue 18507
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.1.3
Hardware: PC Windows XP
: P4 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2004-09-28 07:01 UTC by henkfikkert
Modified: 2004-10-08 12:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Import behaviour: outline and bulleting changes;line addition (56.00 KB, application/msword)
2004-09-28 07:04 UTC, henkfikkert
no flags Details
screenshots comparing text result in WORD2000 and OOO (152.43 KB, application/vnd.sun.xml.draw)
2004-09-28 16:05 UTC, Rainer Bielefeld
no flags Details
File showing empty paragraphs deleted with change tracking turned on in MS Word. Empty paragraphs are not deleted in OOo, only the third paragraph with text (the letter "c"). (23.50 KB, application/msword)
2004-09-29 11:27 UTC, sakitc
no flags Details
More examples of (in)correctly importing deleted new lines in revised files (23.50 KB, application/msword)
2004-09-29 13:01 UTC, sakitc
no flags Details
b.doc reproduced in OO.o (5.61 KB, application/vnd.sun.xml.writer)
2004-10-01 14:35 UTC, sakitc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description henkfikkert 2004-09-28 07:01:43 UTC
When importing (some) bulleted Word document, additional lines and bullets are
added, and others are removed. A Word97 saved document to show this behaviour is
available. (used OOo 1.1.3RC3)
Comment 1 henkfikkert 2004-09-28 07:04:58 UTC
Created attachment 17965 [details]
Import behaviour: outline and bulleting changes;line addition
Comment 2 henkfikkert 2004-09-28 07:07:41 UTC
Occured also in previous versions. 
Comment 3 Rainer Bielefeld 2004-09-28 16:01:46 UTC
I checked with 1.1.2RC3  (German) WIN XP: [645m44(Build8784)] and can confirm
that OOo inserts "Linefeeds" and also bullets (after text "Kosten kunnen zonder
..." for an empty textline.

In the attached screenshot you can see that very often OOo inserts "Linefeeds",
as you see in the red marked paragraphs (same number for same paragraph). But
sometimes OOo imports correct from the document, as you see green marked.

It would be interesting to know a way to make that reproducible with WORD. I
cant't believe that this is a general problem, we would have had bug reports.
For me the question is, what special circumstances in the example document cause
that problem. Reporter, can you contribute more information?

As long as we do not find out that that is a general WORD import problem, P4
should be enough.

Rainer
Comment 4 Rainer Bielefeld 2004-09-28 16:05:26 UTC
Created attachment 17980 [details]
screenshots comparing text result in WORD2000 and OOO
Comment 5 Rainer Bielefeld 2004-09-28 16:14:25 UTC
Oops, in "incorrect_paragraphs.sxd" both "No1" examples should be marked red for
"wrong import", only "11" is green for 'correct'.

Rainer
Comment 6 Rainer Bielefeld 2004-09-28 16:17:11 UTC
I checked with 2.0 (1.9.m51) English version WIN XP: [680m51(Build8801)] and saw
the same problem.

Rainer
Comment 7 Rainer Bielefeld 2004-09-28 16:23:52 UTC
I made some tests with WORD2000 and created some small texts with lists, all has
been imported without problem. Must be something special with "OORefDoc.doc"?

Rainer
Comment 8 henkfikkert 2004-09-28 17:33:09 UTC
Rainer, I'm not sure if the document contains non-standard items. It may well
have to be related to bulleting (e.g. levels change) I remember import bulleting
issues open. Don't know if it's worth a P3. I did observe a failing import. And
a resulting document (LF's removed, bulleting made moer clean and saved from OOo
in doc format) wasn't correctly shown in a receiving user's Word installation. 
I guess it's not only an import but also an export issue, related to something
odd in this doc. 
Comment 9 sakitc 2004-09-29 11:11:14 UTC
When opening OORefDoc.doc with changes in the document shown (Edit - Changes -
Show in OO.o, I am not sure about Word menus, because I am using Croatian
version), you can see that the additional lines shown in
incorrect_paragraphs.sxd had been there, but were deleted by one of the
reviewers. So I think the real question is why text was correctly deleted and
empty paragraphs were not.
Comment 10 sakitc 2004-09-29 11:27:50 UTC
Created attachment 17992 [details]
File showing empty paragraphs deleted with change tracking turned on in MS Word. Empty paragraphs are not deleted in OOo, only the third paragraph with text (the letter "c").
Comment 11 Rainer Bielefeld 2004-09-29 11:33:46 UTC
sakitc, *that* sounds interesting!

Rainer
Comment 12 henkfikkert 2004-09-29 12:07:52 UTC
What I did before I send the document: The original document was larger. I
deleted (in Word) some 3 pages. But the behaviour remained the same. I'm happy
to enter the original, although I guess it will not add new information: the
behaviour is illustrated.
Comment 13 sakitc 2004-09-29 13:01:31 UTC
Created attachment 17993 [details]
More examples of (in)correctly importing deleted new lines in revised files
Comment 14 sakitc 2004-09-29 13:04:15 UTC
In the above attachment (b.doc) you can see that only deleted new lines
contained within deleted text are deleted when you import revised MS Word
documents into OO.o.
Comment 15 sakitc 2004-09-29 13:18:18 UTC
To be more precise: when I said "revised text" in my last comment, I meant "text
edited with change tracking turned on".
Anyway, you should be able to see for yourself, if you compare b.doc when opened
in MS Word and when imported in OO.o.
If this issue affects all documents in which tracked changes haven't been
accepted/rejected, perhaps it would make sense to raise priority a bit?
Comment 16 sakitc 2004-10-01 14:35:05 UTC
Created attachment 18052 [details]
b.doc reproduced in OO.o
Comment 17 sakitc 2004-10-01 14:49:12 UTC
I created another attachment: b-native.sxw, in which I repeated everything I did
when creating b.doc. The difference in the <tracked changes>...</tracked
changes> part of the content.xml files of b.doc and b-native.sxw can be seen in
the following "printouts" of the relevant sections of content.xml for the
imported (from MS Word) and native (OO.o) files:

b.doc

<text:tracked-changes>
  <text:changed-region text:id="ct62595960">
    <text:deletion>
      <office:change-info office:chg-author="tomislav.cepulic"
office:chg-date-time="2004-09-29T13:49:00"/>
      <text:p text:style-name="Standard">deleted</text:p>
    </text:deletion>
  </text:changed-region>
  <text:changed-region text:id="ct62825808">
    <text:deletion>
      <office:change-info office:chg-author="tomislav.cepulic"
office:chg-date-time="2004-09-29T13:49:00"/>
      <text:p text:style-name="Standard">deleted</text:p>
      <text:p text:style-name="Standard">deleted </text:p>
    </text:deletion>
  </text:changed-region>
</text:tracked-changes>

b-native.sxw

<text:tracked-changes>
  <text:changed-region text:id="ct172361400">
    <text:deletion>
      <office:change-info office:chg-author="Tomislav Cepulic"
office:chg-date-time="2004-10-01T15:27:00"/>
        <text:p text:style-name="Standard"/>
        <text:p text:style-name="Standard"/>
    </text:deletion>
  </text:changed-region>
  <text:changed-region text:id="ct172198304">
    <text:deletion>
      <office:change-info office:chg-author="Tomislav Cepulic"
office:chg-date-time="2004-10-01T15:27:00"/>
      <text:p text:style-name="Standard"/>
      <text:p text:style-name="Standard"/>
    </text:deletion>
  </text:changed-region>
  <text:changed-region text:id="ct172308792">
    <text:deletion>
      <office:change-info office:chg-author="Tomislav Cepulic"
office:chg-date-time="2004-10-01T15:27:00"/>
      <text:p text:style-name="Standard">deleted</text:p>
      <text:p text:style-name="Standard"/>
    </text:deletion>
  </text:changed-region>
  <text:changed-region text:id="ct172296272">
    <text:deletion>
      <office:change-info office:chg-author="Tomislav Cepulic"
office:chg-date-time="2004-10-01T15:27:00"/>
      <text:p text:style-name="Standard">deleted</text:p>
      <text:p text:style-name="Standard">deleted </text:p>
    </text:deletion>
  </text:changed-region>
</text:tracked-changes>

You can see that b-native.sxw (or its content.xml) didn't lose any of the four
changes, and b.doc lost all the empty paragraphs (<text:p
text:style-name="Standard"/> parts in b-native.sxw's content.xml)
Comment 18 sakitc 2004-10-01 14:52:21 UTC
Of course, when I said "content.xml of b.doc" in my last post, I meant
"content.xml of the OpenOffice.org file saved after importing b.doc into
OpenOffice.org."
Comment 19 michael.ruess 2004-10-08 12:28:10 UTC
Known issue, problem here is, that OO's concept with numbering/bullets in
tracked changes in a bit different form MS Word's. Duplicate to issue 18507.

*** This issue has been marked as a duplicate of 18507 ***
Comment 20 michael.ruess 2004-10-08 12:35:41 UTC
Closing duplicate.