Issue 34874 - Cannot change installation directory after removing a component from installation list
Summary: Cannot change installation directory after removing a component from installa...
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 680m55
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
: 40967 43576 47026 (view as issue list)
Depends on:
Reported: 2004-10-01 13:55 UTC by carsten.driesner
Modified: 2013-08-07 15:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Install Pic #1 (648.70 KB, image/bmp)
2004-12-19 22:40 UTC, peschtra
no flags Details
Install Pic #2 (606.38 KB, image/bmp)
2004-12-19 22:41 UTC, peschtra
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description carsten.driesner 2004-10-01 13:55:45 UTC
Steps to reproduce this problem:

1. Start setup
2. Click until you reached the 
3. "Change"-button to change the installation directory is enabled.
4. Deselect a component from installation (f.e. "Fonts")
5. The "Change" button of the dialog is disabled. I am not able to change the
installation directory anymore. Why?
Comment 1 2004-12-01 11:36:13 UTC
Will be fixed later
Comment 2 peschtra 2004-12-19 22:39:12 UTC
I tried this in 1.9.65 and I saw what happened at first.

I went to custom, expanded the optional components area and deselected the
python bridge thing, the change button grayed out. However...

I then selected another component, or minimized the custom listr and then the
button un grayed out.

See the two pictures I attached. 

Closing works for me.

Comment 3 peschtra 2004-12-19 22:40:24 UTC
Created attachment 20667 [details]
Install Pic #1
Comment 4 peschtra 2004-12-19 22:41:16 UTC
Created attachment 20668 [details]
Install Pic #2
Comment 5 Olaf Felka 2005-01-19 18:23:31 UTC
*** Issue 40967 has been marked as a duplicate of this issue. ***
Comment 6 Olaf Felka 2005-01-19 18:26:10 UTC
Still the same behaviour: The button is greyed out if a component is deselected.
Comment 7 peschtra 2005-01-21 03:08:10 UTC
Out of curiosity, did you try what I suggested, because it worked for me?

What OS are you using, maybe it has to do with your OS's installer. In Win XP no
SP2 it worked okay if you follow my steps below.
Comment 8 Olaf Felka 2005-01-21 08:40:53 UTC
The 'bug' is that for all deselected modules the >Change< button is disabled. No
matter what OS is running.
Comment 9 peschtra 2005-01-22 02:23:06 UTC
Okay, I don't know how you could make sure a sweeping statement since OOo now
uses the OS's installed to install. Have you seen the error on every OS?

You also didn't answer me second question, did you try selecting a second
component? When you did that, did the button ungray as I sugeested it would on
19 Dec?
Comment 10 peschtra 2005-01-23 19:14:29 UTC
In 1.9.72 this seems to be fixed.

When you deselect a component the entire option to set the directory disappears,
because that component can't beinstalled (There is a red x on it) However if you
click on a component you are going to install, the change directory options
opens again.
Comment 11 Olaf Felka 2005-01-24 14:06:44 UTC
The intention is to keep the button enabled on a deselected component. The
Destination for the installation belongs to the whole office and not to the
component so the button should stay enabled even if the component has been
deselected. This behaviour has always been the same since the new installer has
been introduced and has never been fixed.
Comment 12 peschtra 2005-01-25 02:42:09 UTC
What functionality are you losing right now under the way that the installer is
set up?
Comment 13 Olaf Felka 2005-02-26 15:28:30 UTC
*** Issue 43576 has been marked as a duplicate of this issue. ***
Comment 14 Olaf Felka 2005-04-08 15:35:24 UTC
*** Issue 47026 has been marked as a duplicate of this issue. ***