Issue 34927 - OOo does not display images properly in rtf file
Summary: OOo does not display images properly in rtf file
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.1.2
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo, oooqa
Depends on:
Reported: 2004-10-04 08:06 UTC by pmakde
Modified: 2017-05-20 11:19 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

rtf file 1 (2.09 MB, application/msword)
2004-10-04 08:08 UTC, pmakde
no flags Details
rtf file 2 (101.18 KB, application/msword)
2004-10-04 08:09 UTC, pmakde
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description pmakde 2004-10-04 08:06:45 UTC
The attached rtf file is not properly displayed by the OpenOffice.
It doesnt display some of images in these files.
Comment 1 pmakde 2004-10-04 08:08:31 UTC
Created attachment 18100 [details]
rtf file 1
Comment 2 pmakde 2004-10-04 08:09:25 UTC
Created attachment 18101 [details]
rtf file 2
Comment 3 rvojta 2004-10-04 11:24:36 UTC
*** Issue 34928 has been marked as a duplicate of this issue. ***
Comment 4 Rainer Bielefeld 2004-10-04 13:08:03 UTC
Hm, with 1.1.2RC3  (German) WIN XP: [645m44(Build8784)] and WIN2000 it seems to
bee quite the opposite.

I opened 'Efficacy_8111.rtf' with OOo and also WORD2000 (WIN XP) and saw:
With WORD absolutely no image in the text
With OOo several images in the text, but several ones seem to be misplaced

For '5_wn_8111.rtf' I can confirm the reported problems
With WORD I see three images at the top of page 1
With OOo no image visible there.

I also tried to open both files with WORKS 4.5a, which also has problems with
both files:
'5_wn_8111.rtf': only "sales logix"-image is shown at top of page 1
'Efficacy_8111.rtf': images are shown, but misplaced

Reporter, please contribute more precise information:
0. pls. try to decide, whether we should not have separate issues for bot
documents, because the problems might be different. 
1. With what program (version) have the documents been created
2. With what other program (WORD version (?)) did you open the documents?
3. please describe exactly each abnormality you see. best will be you create
   a '.sxd' Draw- Documents where you can list and describe screenshots which 
   compare view in OOo and view with WORD (?) 

An expert might have a look on the documents and check, whether it are correct


Comment 5 Rainer Bielefeld 2004-10-04 13:08:31 UTC
changed subcomponent
Comment 6 michael.ruess 2004-10-07 15:25:03 UTC
The problem with the second file seems to be solved in OO 2.0. there I can see
exactly one Graphic; like with MS Word 2003.

MRU->MMAHER: take the first attachment. Open this one with 680m55 and see that
there is two times the same graphic. There should be three different graphics.
Comment 7 martin_maher 2005-05-05 10:28:25 UTC
mmaher->flr: Your's methinks
Comment 8 Rainer Bielefeld 2005-06-18 09:11:59 UTC
Problem still visible in 2.0 (1.9.m104) English version WIN XP:
[680m104(Build8913)]. pls also see issue 43833 and related ones.
Comment 9 Mathias_Bauer 2006-08-30 15:16:29 UTC
reassigning to hbrinkm
Comment 10 ace_dent 2008-05-14 23:41:24 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please re-test with one of the latest versions of OOo -
the problem(s) may already be addressed. Either use the latest stable version:
or consider trying the new OOo 3 BETA (still in testing):

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future. You may also wish to search for (and note) any duplicates of this Issue
that may have progressed further :


Cleaning-up and Closing old Issues as part of:
~ The Grand Bug Squash, pre v3 ~
Comment 11 Risto Jääskeläinen 2008-09-27 16:17:15 UTC
Neither files 8111.rtf or Efficacy_8111.rtf displays any pictures in WordPad in
Vista. So I don't see, if no picutres is really problem of in
these cases. Anyhow, no image with OOO300 either.

Best regards
Risto Jääskeläinen
Comment 12 Marcus 2017-05-20 11:19:50 UTC
Reset assigne to the default "".