Issue 35596 - Better handling of m-dash and n-dash
Summary: Better handling of m-dash and n-dash
Status: CLOSED DUPLICATE of issue 5018
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 1.1.3
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-15 10:19 UTC by ahjulsta
Modified: 2008-11-05 20:31 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ahjulsta 2004-10-15 10:19:39 UTC
The m-dash and n-dash handling does not take proper use into account. There are
simple guidelines for the use of these punctuation symbols in text, and it would
be greatly usefull if this was supported by OO. I write most of my texts in
Norwegian so following argument reflects this. I would expect there to be
localization issues.

In regular text one finds three different dashes. The hyphenation mark, the
n-dash and the m-dash. Here, I will refer to these symbols by '-', '--' and
'---' respectively. The reasoning behind the names n-dash and m-dash is that the
dashes have the same length as the letters n and m.

The simplest first: '---'. the m-dash is used as a delimiter, separating parts
of a period. There should not be spaces around the m-dash. (However, I guess it
is allowed to divide a line after an m-dash.
"This had never happened before---and would most likely never happen again---had
it not been..."

Then, the n-dash: '--'. It is used to separate the endpoints of an interval:
"The opening hours are 8--10 every morning." and "The train Oslo--Bergen.". And
also: "The Liverpool--Arsenal football match" (this is how it is in Norwegian,
at least).

Finally, there is the hyphenation mark, used in most (all?) other cases. (In
addition, the minus sign can be a slightly different symbol from the hyphenation
mark, especially in formulas.)

Having summarized the relevant symbols, I will now suggest how this can be used
to improve OO. Most importantly: One should not infer anything from the presence
 (or lack of presence) of spaces when handling n- and m-dashes. It is
particularily annoying to get an m-dash when writing intervals.

Inserting the symbols manually should be easily accomplished using few
keystrokes. For example Menu: "Insert | Symbol | Hyphenation (tabbed pane?) |
m-dash (radio button?)". At this point one should not have to consider fonts, we
want to insert a symbol from the font of the running text.

Autocorrect should by default (or easily) be configured to replace all
occurences of '--' with n-dash and '---' with m-dash when typing, regardless of
spaces. This is consistent with the expectations of LaTEX users.

I haven't thought of whether OO should consider n-dashes as candidates for
dividing expressions over two lines, sometimes ("8--10") it seems inappropriate,
whereas in other cases ("Kristiansand--Trondheim", a route between two cities in
Norway with somewhat long names) I guess one should split lines.

I believe this is an important issue to many authors.
Comment 1 michael.ruess 2004-10-15 11:34:00 UTC
reassigned to BH.
Comment 2 stefan.baltzer 2007-07-18 17:06:15 UTC
SBA: In my opinion, this one is a duplicate of enhancement issue 5018.

*** This issue has been marked as a duplicate of 5018 ***
Comment 3 Mechtilde 2008-11-05 20:31:07 UTC
close the duplicate