Issue 35655 - Most recently used fonts in Format>Font droplist
Summary: Most recently used fonts in Format>Font droplist
Status: CLOSED DUPLICATE of issue 6737
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-10-16 21:37 UTC by jltallon
Modified: 2004-10-17 18:15 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jltallon 2004-10-16 21:37:53 UTC
It would be *very nice* to have the font-selection drop-list remember the latest 
4 ó 5 fonts, à la Microsoft Office.
Since most documents use at most 3 or 4 fonts, this provides a big usability 
enhancement...as well as better productivity for the user.
Styles yield a *similar* solution, but sometimes they are too overkill (and 
besides, this smoothens the transition from MSOffice :-)
Comment 1 Regina Henschel 2004-10-16 23:43:57 UTC
You can check 'Font history' in Tools - Options - Openoffice.org - View. Then
you get the fonts, which you have last applied, at the top of the list.
The 'Apply Style'-list on the left side of the objectbar shows the styles which
are used in the document.
Are these the functions you want?
Comment 2 jltallon 2004-10-17 11:43:34 UTC
* The 'Apply Style'-list provides a *similar* functionality, agreed. (but this 
is not what i was referring to...)

* What i proposed was a modification to the Format Toolbar's font drop-down 
list:
+-----------+
| MRU font 1|
| MRU font 2|
+-----------+
| font name1|
| font name2|
|  . . . .  |
|  . . . .  |
| font nameN|
+-----------+

where "font name" 1-N are the names of the available fonts(just like in current 
versions)

RATIONALE: Sometimes (even though it is not a best practice), one needs to 
change fonts without changing the style(i.e. keep the 'default' style), and do 
so frequently within a document.
Having a history of the last 4 or 5 most recently used fonts increases 
productivity (the user does not need to scroll down to the particular font she 
wants, but just choose among the first 4 entries in most cases).

Again, this is just a very minor issue. Thank you all for your work.
Comment 3 lohmaier 2004-10-17 18:15:08 UTC
There already is a font-history in the control in the toolbar.

There's already another issue regarding the font-history in every dialog. ->
duplicate.

*** This issue has been marked as a duplicate of 6737 ***
Comment 4 lohmaier 2004-10-17 18:15:26 UTC
closing duplicate.