Issue 35727 - HTTP session switched when .sxc file loaded from Java servlet
Summary: HTTP session switched when .sxc file loaded from Java servlet
Status: CLOSED DUPLICATE of issue 19510
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 1.1.3
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: AOO Later
Assignee: mikhail.voytenko
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-18 16:07 UTC by weber5
Modified: 2010-11-10 16:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description weber5 2004-10-18 16:07:25 UTC
I am having problems using the OpenOffice browser plug-in to view an .sxc
spreadsheet file delivered by a Java servlet.  I have OpenOffice 1.1.3 installed
on a Windows 2000 system.  I am using Internet Explorer 6 to invoke the servlet
via an HTTP URL.  The URL contains a parameter which identifies HTTP session
information used to locate the file.  The servlet successfully returns the
contents of the file.  The servlet then receives a second HTTP request for the
same file.  This second request, which I believe is issued by the OpenOffice
plug-in, uses a different HTTP session.  Since the session is different, the
servlet is not able to find the file location information and the request fails.  

If you contact me via my e-mail address, I can give you access to a test system
where this servlet is deployed so you can recreate the problem.
Comment 1 frank 2004-10-19 08:25:58 UTC
Hi,

I think this is something for the framewwork team, as it is related to the pugin
itself. So I re-assign it.

Frank
Comment 2 frank 2004-10-19 08:26:27 UTC
Hi Uwe,

I think this is yours.

Frank
Comment 3 uwe.luebbers 2004-10-22 09:45:20 UTC
Hi Robert,

Any ideas?

Regards, Uwe
Comment 4 uwe.luebbers 2004-12-02 13:49:54 UTC
Hi James,

Do you have any ideas?

regards, Uwe
Comment 5 jmeng 2004-12-03 01:46:51 UTC
Hi, Uwe
This is a issues for IE Plugin, not for Mozilla plugins. Please reassign to the
owner of IE activeX plugin. I am not sure who is him.
While Mikhail and Andreas had explained how IE plugin worked to me when I was
developing Mozilla plugin(Thanks to them here again:)), so I can give some clue.
When load document, IE plugin does not get the remote file form IE but load it
from internet directly.  So I think the first HTTP session is used by IE, and IE
plugin dose not ues this session and try to created a new session to get the URL
itself. 
Mozilla plugin should not has this issues. It let Mozilla to download the URL
file, and do not create any session itself. 
Comment 6 uwe.luebbers 2005-01-07 14:55:39 UTC
Hi Carsten,

Any ideas what's going wrong?
Comment 7 carsten.driesner 2005-01-07 15:50:56 UTC
CD->mav: Mikhail can you please have a look.
Comment 8 mikhail.voytenko 2005-01-10 08:00:13 UTC
The URL is used directly by the office to allow relative links opening. A fix
could be to provide an imputstream representing local copy of the document with
the original URL.
Comment 9 weber5 2005-01-17 16:02:38 UTC
I would be happy to try out a fix if you have one available.

Thanks! Janet
Comment 10 mikhail.voytenko 2007-01-02 15:21:15 UTC
The fix for the issue 19510 should fix this problem as well.

*** This issue has been marked as a duplicate of 19510 ***
Comment 11 mikhail.voytenko 2007-01-02 15:25:42 UTC
The scenario should work well starting from OOo2.0.1
Comment 12 grehtietalders 2010-11-10 16:46:12 UTC
Created attachment 73284