Issue 36410 - Absolute path for INDIRECT Range fails (Err:502) => Network path workaround
Summary: Absolute path for INDIRECT Range fails (Err:502) => Network path workaround
Status: CLOSED DUPLICATE of issue 4695
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1.3
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-31 23:39 UTC by illusion65
Modified: 2004-11-02 13:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description illusion65 2004-10-31 23:39:43 UTC
An absolute path in an INDIRECT Range, fails with Err:502, unless 1) the "file:"
qualifier is removed AND 2) the path is a network drive.  Relative paths work as
expected.  (WinXPsp1; OOo1.1.3)

It does not seem to be related to Issues 4904, 11054 or duplicates, as this
affects fixed cell ranges.

For example: 
if local cell B10 has: 'file://Computer2/subd1/subd2/Calc.sxc'#Sheet1.C4:C10
	and B11 has =SUM(INDIRECT(B10)) => Err:502

but if B10 has: '//Computer2/subd1/subd2/Calc.sxc'#Sheet1.C4:C10
	then B11 displays the expected value.

NOTE: this only fails if it is a RANGE within an INDIRECT statement.  The
reference works with "file:" if it is referencing a single cell, or if the
remote range is specified directly inside a function, such as:

=SUM('file://Computer2/subd1/subd2/Calc.sxc'#Sheet1.C4:C10)  => works.

It's an easy work-around, though it only works for network drives (If you share
your local drive on the network, then you can reference local files through the
network mapping), but I thought it should be documented.  It may even be easy to
fix!  Thanks to everyone for such a great product!  I really appreciate it.
Comment 1 frank 2004-11-02 13:41:57 UTC
Hi,

this is a double to Issue 4695

Frank

*** This issue has been marked as a duplicate of 4695 ***
Comment 2 frank 2004-11-02 13:42:21 UTC
closed double