Issue 36814 - GDI Metafile Font location wrong
Summary: GDI Metafile Font location wrong
Status: ACCEPTED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1.3
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-08 08:27 UTC by hare
Modified: 2013-02-07 21:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
GDI Object in a version 1.0.1 document (6.56 KB, application/vnd.sun.xml.writer)
2004-11-08 08:53 UTC, hare
no flags Details
GDI Object in Ooo1.3.1 document (6.61 KB, application/vnd.sun.xml.writer)
2004-11-08 08:54 UTC, hare
no flags Details
Graphic file used to copy paste (5.77 KB, application/x-compressed)
2004-11-11 15:15 UTC, hare
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hare 2004-11-08 08:27:30 UTC
By inserting a graphic as GDI Metafile, the font location is shifted. This 
behavior is first seen on version OOo 1.1.2. 
In Version 1.0.1 the insertion of GDI Metafiles was working correctly.
Comment 1 hare 2004-11-08 08:53:21 UTC
Created attachment 19048 [details]
GDI Object in a version 1.0.1 document
Comment 2 hare 2004-11-08 08:54:02 UTC
Created attachment 19049 [details]
GDI Object in Ooo1.3.1 document
Comment 3 michael.ruess 2004-11-11 14:21:59 UTC
From the attachment I can see that there is something wrong. But I cannot get
the way how to recieve such a damaged graphics. What I did: opened the 1.0.1
file in OO 1.1.x, copied the graphic to clipboard and than inserted as GDI into
a new document and it looked good.
Perhaps we need the original graphic file to reproduce the problem? If so,
please attach this here and feel free to reopen the issue when you have done so.
Comment 4 hare 2004-11-11 15:15:40 UTC
Created attachment 19182 [details]
Graphic file used to copy paste
Comment 5 hare 2004-11-11 15:18:57 UTC
The missplaced text in the GDI file can only be seen if copy past from Corel 
Draw 9 to OpenOffice 1.1.x. In Version 1.0 this issue could not be seen. If the 
graphic is exported to a .wmf file and this file is imported, the graphic looks 
fine.
Comment 6 michael.ruess 2004-11-16 15:18:27 UTC
MRU->SJ: Open the attached .cdr in Corel Draw (tested with Corel 10 on WG's
machine) and copy the content to Clipboard. Then insert it into any OO
application as GDI Metafile via "Edit.Paste special" and see the text strings
move to wrong places.
Comment 7 ooo 2004-12-01 15:59:20 UTC
set to prio4
Comment 8 sven.jacobi 2005-04-01 17:12:01 UTC
sj: target -> OOo 2.01, prio -> p3
Comment 9 sven.jacobi 2005-05-18 10:09:20 UTC
accepted
Comment 10 sven.jacobi 2005-05-24 11:53:05 UTC
Because of a too huge workload I can't fix this issue for OOo 2.01 -> changed
target to OO Later.