Issue 36892 - don't change scrollbar position after saving files
Summary: don't change scrollbar position after saving files
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: current
Hardware: All All
: P4 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@sw
URL:
Keywords:
: 69305 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-11-09 09:38 UTC by glu
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description glu 2004-11-09 09:38:36 UTC
Currently in Writer, if you save files when the cursor isn't shown in the
windows, perhaps it's somewhere else, former or latter, after the file's saved,
the scrollbar will change to the position of that cursor. It's sometimes
annoying. Because if users just browse the document, perhaps in order to check
errors, probably they don't click the mouse frequently. Probably they just
scrolling the vertical scrollingbar by the rolling mouse, so when they stop
somewhere, and want to save the document, they'd find that the view of document
is changed to an older position where they last click the mouse. It's not quite
friendly. Could you not change the scrolling position after saving files?
Comment 1 glu 2004-11-09 09:39:32 UTC
retarget to OOo 2.0 as enhancement.
Comment 2 bettina.haberer 2004-11-26 15:58:37 UTC
Reset target milestone as no further features get into OO.o 2.0.
Comment 3 burgesspa 2006-06-15 13:21:17 UTC
This also happens with the automatic save, which I have set to every 1 minute.
So it is very annoying when after a save Ooo moves the view to the cursor
position rather than keeping the current scroll bar postion. Of course the work
around is not to use the scroll bar/mouse wheel, but to use page-up/page-down
instead like I used to use before scrool bar and mouse wheels, but I am used to
using the mouse wheel now.
I have added some votes for this issue. Please fix this soon.
Comment 4 michael.ruess 2006-09-06 09:05:24 UTC
*** Issue 69305 has been marked as a duplicate of this issue. ***
Comment 5 oooforum (fr) 2006-11-23 13:45:11 UTC
In the same way, if you choose a lower zoom, horizontal scrollbar is always
enabled. You can not to scroll screen to move page in middle position.
Comment 6 jimjutte 2008-03-07 15:44:57 UTC
Has this issue been addressed? I have not been able to use OOo since about 2.1
or 2.2, (about a year) because of this problem. There won't be votes for people
seeing this issue, because they can't use the product without losing a LOT of
time. This is especially important in longer documents. 
Comment 7 bettina.haberer 2008-03-07 16:10:08 UTC
This should work, please try a current version 2.3 or 2.4.