Issue 37030 - writer can not open/interpret rtf file
Summary: writer can not open/interpret rtf file
Status: CLOSED DUPLICATE of issue 3790
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.1.3
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
Keywords: oooqa
Depends on:
Reported: 2004-11-11 15:25 UTC by kukackam
Modified: 2004-11-12 08:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Table of used CAD objects (lines and textframes) (317.24 KB, text/rtf)
2004-11-11 15:29 UTC, kukackam
no flags Details
screenshot after <cntrl-c> <cntrl-v> of RTF content from WORD to OOO 1.3 (26.12 KB, image/png)
2004-11-11 18:00 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kukackam 2004-11-11 15:25:48 UTC
I tried to open an rtf (Rich Text Format) File generated by an CAD Aplication.
This file contains a lot of lines and textframes. The filesize is about 500kB.
After OOo 1.1.2 and 1.1.3 on OS 2k and XP opened the file without any message I
got some blank pages. There is only a big black standing triangle showing to the
right if the mousepointer is moved to the left paper side (|>). If the mouse
points to the middle there are two triangles pointing to the sides (<|>) and if
the mouse is moved to the right side the triangle points to the left side(<|).
If the mouse is moved outside the page the pages are plain white. 
After this I tried to open the rtf with MS Word and it worked slow but fine,
saved the file to Word6.0 and could open the correct file with OOo.
If you need the rtf file just contact me.

Comment 1 kukackam 2004-11-11 15:29:14 UTC
Created attachment 19184 [details]
Table of used CAD objects (lines and textframes)
Comment 2 Rainer Bielefeld 2004-11-11 17:55:16 UTC
I checked with 1.1.2RC3  (German) WIN XP: [645m44(Build8784)] , and I can
confirm reporters obervations completely. I can open Bhg3D_only_Sockel_F.rtf
with WORD2000 without problems. OOo does not show any content after import. Even
if I save  the RTF with WORD 2000 as .doc, close WORD, reopen WORD, load created
.doc and save with WORD as .rtf again, I will not be able to open that new
document with OOo.

Funny thing: when I open the created new .rtf-document with 2.0 (1.9.m56)
English version WIN XP: [680m56(Build8814)], I get 425 pages, most blank, some
with funny text like
***** TEXTFELD 2 *****            *******************************************
***** TEXTFELD 3 *****            *******************************************
***** TEXTFELD 4 *****            *******************************************
dxTextLeft0dyTextTop0dxTextRight0dyTextBottom" .....

In many of the blank pages, I see a little red arrow at the bottom of the page.

Some expert is required to check, whether 'Bhg3D_only_Sockel_F.rtf' really is

My suspect: some table import problem.
Comment 3 Rainer Bielefeld 2004-11-11 18:00:03 UTC
Created attachment 19188 [details]
screenshot after <cntrl-c> <cntrl-v> of RTF content from WORD to OOO 1.3
Comment 4 Rainer Bielefeld 2004-11-11 18:02:24 UTC
Concerning my "table-suspect", pls. see screenshot "wide_tables.png"! So it
looked, after I copied (<cntrl-c> <cntrl-v>) content from
"Bhg3D_only_Sockel_F.rtf" (opened with WORD2000) to a new OOo Writer document
with page width 119 cm.

Comment 5 kukackam 2004-11-11 18:15:41 UTC
If you save the file from Word as Word 6.0 doc and import it afterwards into OOo
it will work.
Don't ask me why.
Comment 6 michael.ruess 2004-11-12 08:52:08 UTC
All the elements in the attached document are produced as MS drawing objects
(including the "tables"). These objects are currently not supported by OO'S RTF
filter. See issue 3790.

*** This issue has been marked as a duplicate of 3790 ***
Comment 7 michael.ruess 2004-11-12 08:55:21 UTC
closing duplicate.