Issue 37153 - Writer/Web displays double errormessage when Java is missing
Summary: Writer/Web displays double errormessage when Java is missing
Status: CLOSED DUPLICATE of issue 37020
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 680m61
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: joachim.lingner
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-15 09:23 UTC by joerg.skottke
Modified: 2013-08-07 14:41 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description joerg.skottke 2004-11-15 09:23:22 UTC
Automated test: first.bas/tJava

Loading a webpage containing a java applet without having java support installed
triggers the "JRE required" Errormessage at least twice.
Comment 1 joerg.skottke 2004-11-15 09:26:39 UTC
jsk->hi: Can you please redistribute?
Comment 2 h.ilter 2004-11-15 16:20:34 UTC
Reassogned to JL
Comment 3 joerg.skottke 2004-11-18 11:22:05 UTC
This problem has larger impact. When trying to execute macros without Java
enabled the user is confronted with countless warnings. Executing the BASIC
macro is not possible then. But BASIC macros can be run when using the BASIC
macro organizer instead. 

Possible solutions:
- disable everything that triggers the scripting framework including all menuentries
- force the user to install Java
- bring up one single errormessage that informs the user about the impact of not
having Java installed.
- bring up one errormessage at office startup and then just ignore any attempts
to trigger Java
- ...

I think this is a big thing that cannot be fixed for 2.0 but please see what you
can do. Considering the slick userinterface we introduce with OOo 2.0 this is a
bad performance. UI change required. I would consider this relevant for 2.1 (or
whatever the Patch might be called)

Comment 4 duncan.foster 2004-11-18 11:27:28 UTC
Adding Tom to the cc.
Comment 5 joachim.lingner 2004-11-18 11:49:31 UTC
.

*** This issue has been marked as a duplicate of 37020 ***
Comment 6 joachim.lingner 2005-02-28 12:45:38 UTC
.