Issue 37510 - problem starting with corrupt configuration
Summary: problem starting with corrupt configuration
Status: CLOSED DUPLICATE of issue 23220
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 1.1.3
Hardware: All All
: P2 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-11-21 10:01 UTC by bobharvey
Modified: 2005-02-14 15:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bobharvey 2004-11-21 10:01:35 UTC
A friend of mine had problems starting the application and got the following
message:

Open Office Cannot be started due to an error accessing Openoffice.org
configuration data
The following internal error has occured: GetStorage, name:"NoContent 

In the end I had to re-create his profile to get it going again.  SInce then I
have come across:
http://www.oooforum.org/forum/viewtopic.php?t=14380

which is exactly the same problem for someone else.  My friend's installation
was rendered useless - he even tried a re-install, but the profile was
preserved.  This is far too difficult a situation for unskilled users to fix.

I would like to propose either (or both) of the following fixes:

1.  The error message is made more explicit so that the faulty file is identified.
2.  If the file is corrupted, why cannot OOo offer to repair it automatically? 
Or just do it anyway?
Comment 1 bobharvey 2005-02-07 16:57:23 UTC
I've just done a search on the Forums for "GetStorage, name" and found 17
threads.  What does it take to confirm something?
Comment 2 haxwell 2005-02-07 17:56:33 UTC
Please have a look at issue 23220 for information on how to clear up this issue.

OOo v1.9.74 does not have this problem.

*** This issue has been marked as a duplicate of 23220 ***
Comment 3 mci 2005-02-14 15:55:26 UTC
closing this issue since it's duplicate...