Issue 38093 - Copying autofilter results in an XLS document.
Summary: Copying autofilter results in an XLS document.
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.1.3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
: 40224 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-11-29 16:54 UTC by ulises
Modified: 2013-08-07 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ulises 2004-11-29 16:54:08 UTC
I´ve an XLS document (doesn´t matter if it was created with OO or Excel..the 
same happens in both cases), then I apply an autofilter and save the document. 
Then I open the file and when I try to copy the result, Calc doesn´t copy just 
the rows I selected but the other ones that are hydden. I´ve to apply the 
filter again and then it works fine (just copy the selected rows). 
I dont have that problem in Calc .sxc documents.
It seems that Calc doesn´t recognize the rows as a result of a filter but as 
hydden rows..so it copies them all..(acording to the help).
Sorry for my english.
Thanks.
Comment 1 frank 2004-12-07 16:30:16 UTC
Hi Daniel,

your construction site ?

Maybe for 2.0 ?

Frank
Comment 2 daniel.rentz 2004-12-08 14:38:33 UTC
2.0 is possible, accepted & started
Comment 3 daniel.rentz 2004-12-20 20:48:26 UTC
fixed in SRC680/dr31 (OOo 2.0)
Comment 4 daniel.rentz 2005-01-10 15:47:39 UTC
reopened
Comment 5 daniel.rentz 2005-01-10 15:48:15 UTC
back to QA
Comment 6 daniel.rentz 2005-01-10 15:50:30 UTC
fixed.

Behaviour after import is now equal to spreadsheets created in Calc:

Copying from a filtered area leaves out hidden rows.
Copying from an area with manually hidden rows copies all rows.
Comment 7 oc 2005-01-13 09:27:58 UTC
*** Issue 40224 has been marked as a duplicate of this issue. ***
Comment 8 oc 2005-01-13 14:09:31 UTC
verified in internal build cws_dr31
Comment 9 oc 2005-01-20 14:45:46 UTC
closed because fix available in OOo1.9m72