Issue 38428 - Cannot delete containing folder of Documents
Summary: Cannot delete containing folder of Documents
Status: CLOSED DUPLICATE of issue 19453
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 1.1.4
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-12-04 14:54 UTC by matt_k
Modified: 2004-12-07 21:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description matt_k 2004-12-04 14:54:10 UTC
Note: OO = Open Office
You cannot delete a folder that contains or contained a document that was opened
in OO if OO is still running and no other file has been opened.
How to recreate.
1: Create a folder in "My Documents". 
2: Create a document in the folder using any application (MSWord, OO or text editor)
3: Open the Document in OO.
4: Close the Document in OO (File / Close), but do not close OO appication.
5: Delete the FOLDER that contains the document via MSWindows Shell (right click
on folder, select delete from menu or highlight the folder or use the delete
icon at the top of the toolbar)
Defect >>
6: I am not allowed to delete the folder. I get the following pop-up message.
"Cannot delete TestOO: It is being used by another person or program. Close any
programs that might be using the file and try again."
Exceptions and workarounds: 
If you open another file in a different folder, you can then delete the initial
folder.
If you close OO, you can delete the folder as normal.
other notes: I tried this using docs made with MSword2000 and Docs created with
OO in existing and new folders. Same result regardless.
Comment 1 matt_k 2004-12-04 14:58:27 UTC
I forgot to include that this does not apply to the file which can be deleted
per normal in my tests.
Comment 2 lohmaier 2004-12-05 14:24:33 UTC
are you using the windows-Sytem file-open dialogs or the OOo-ones?
Comment 3 eric.savary 2004-12-05 15:41:31 UTC
Reassigned to Framework
Comment 4 matt_k 2004-12-05 16:14:33 UTC
Ummm. As I opened the file in OO (in OO, tab "File", select "Open" from the drop
down menu). I would say I am using the OO file open dialog.
Note: I get the same result if I open the file with a (double) left-click in
explorer.
That answers the question I hope.
Comment 5 lohmaier 2004-12-06 21:14:34 UTC
please check your settings in Tools|Options -> OOo -> general

Make sure you close all instances of OOo including the quickstarter after you
changed the setting.

(see also issue 19453)
Comment 6 matt_k 2004-12-06 22:59:04 UTC
settings in Tools|Options -> OOo -> general >>  The open/save dialogs were NOT
checked. I clicked the box "Use OpenOffice.org dialogs" , I then opened my
document, closed it and then deleted the folder (in windows) without issue (I
did not have to exit OO as before).  
Notes: I have never used the quickstarter and I did not use it this time either.
I guess there is some technical reason that the "Use OpenOffice.org dialogs" is
not on by default?
Problem Solved. Thanks. 
Comment 7 lohmaier 2004-12-07 21:22:15 UTC
Thanks for the answer.
In this case it is a duplicate of issue 19453

It is not a technical reason why the OOo dialogs are not the default.

OOo should integrate as much as possible with the system and thus tries to use
the system features where possible.

*** This issue has been marked as a duplicate of 19453 ***
Comment 8 lohmaier 2004-12-07 21:23:06 UTC
closing duplicate.