Issue 38482 - Add "project in charge" column to "Description of the Modules"
Summary: Add "project in charge" column to "Description of the Modules"
Status: CLOSED FIXED
Alias: None
Product: Build Tools
Classification: Code
Component: www (show other issues)
Version: current
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: Martin Hollmichel
QA Contact: issues@tools
URL: http://tools.openoffice.org/modules.html
Keywords:
: 22882 (view as issue list)
Depends on:
Blocks:
 
Reported: 2004-12-06 10:32 UTC by bluedwarf
Modified: 2013-08-07 15:34 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Proposal: new "Modules" page (105.26 KB, text/html)
2004-12-13 16:12 UTC, bluedwarf
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bluedwarf 2004-12-06 10:32:43 UTC
In "Description of the Modules" ( http://tools.openoffice.org/modules.html ), we
cannot find which project handles the modules now. If we cannot know which
project handles the module where compilation error occures, we will get confused
about which project (called "component" in IssueZilla) we must choose before
submits a issue.

Would you add "Project in charge" column to "Description of the Modules" table?

Regards,
Comment 1 Martin Hollmichel 2004-12-08 14:52:44 UTC
confirmed. any volunteer to take this issue ?
Comment 2 bluedwarf 2004-12-09 06:36:56 UTC
I've created a table showing module and project in charge in CSV format following:

Module,Project in charge
transex3,l10n
offuh,api
dbaccess,dba
connectivity,dba
sfx2,framework
res,framework
idl,framework
desktop,framework
sd,graphics
sch,graphics
goodies,graphics
svx,graphics
vcl,gsl
rsc,gsl
toolkit,gsl
UnoControls,gsl
forms,gsl
setup2,installation
scptools,installation
readlicense,installation
extras,installation
wizards,installation
so3,oi
sj2,oi
sal,porting
sc,sc
scaddins,sc
basic,script
basctl,script
sw,sw
starmath,sw
solenv,tools
dmake,tools
xml2cmp,tools
config_office,tools
uui,ucb
ucbhelper,ucb
store,ucb
cppu,udk
cppuhelper,udk
javaunohelper,udk
jurt,udk
bridges,udk
remotebridges,udk
stoc,udk
cpputools,udk
registry,udk
codemaker,udk
rdbmaker,udk
vos,udk
unoil,udk
tools,util
svtools,util
io,util
eventattacher,util
unzip,util
unotools,util
extensions,util
external,util
configmgr,util
sot,util
automation,util
comphelper,util
jut,util
officecfg,util
sandbox,util
fileaccess,util
xmlhelp,util
xmloff,xml
sax,xml
framework,framework
ucb,ucb
udkapi,api
offapi,api
ridljar,udk
lingucomponent,whiteboard
package,xml
linguistic,sw
XmlSearch,util
odk,api
dtrans,gsl
xmlscript,script
salhelper,udk
idlc,udk
soltools,tools
sysui,gsl
shell,gsl
testshl,tools
psprint,gsl
padmin,gsl
testtools,udk
berkeleydb,external
moz,external
fpicker,gsl
sablot,external
MathMLDTD,external
i18npool,l10n
stlport,external
freetype,external
nas,external
neon,external
filter,framework
psprint_config,external
expat,external
cosv,tools
udm,tools
autodoc,tools
np_sdk,external
zlib,external
icu,external
accessibility,gsl
jpeg,external
netbeans_integration,external
curl,external
unixODBC,external
scripting,framework
testshl2,tools
jvmaccess,udk
boost,external
readlicense_oo,installation
sane,external
twain,external
rvpapi,gsl
qadevOOo,qa
embedserv,framework
i18nutil,l10n
regexp,external
x11_extensions,external
sdk_oo,api
crashrep,porting
python,external
bitstream_vera_fonts,external
dictionaries,external
pyuno,udk
beanshell,external
rhino,external
cli_ure,udk
hwpfilter,sw
embeddedobj,framework
libxml2,external
unoxml,framework
scp2,installation
canvas,gsl
cppcanvas,gsl
slideshow,graphics
chart2,graphics
basegfx,graphics
msfontextract,external
jvmfwk,udk
xmerge,xml
instsetoo_native,installation
binfilter,framework
bean,api
setup_native,installation
xmlsecurity,xml
libxmlsec,external
helpcontent2,documentation
libwpd,external
writerperfect,sw
avmedia,graphics
portaudio,external
sndfile,external
smoketestoo_native,installation
hsqldb,external
Comment 3 bluedwarf 2004-12-09 06:42:20 UTC
Sorry, the previous table was craeted with 680 source code. Anybody make a table
like that with 645 source code? I've made it with following ruby script. Please
refer to this script.

#/usr/bin/ruby

puts "Module,Project in charge"
        
current_dir = Dir.pwd
Dir.foreach(current_dir) { |mo|
  path = File.join(current_dir,mo)
  path = File.join(path,"CVS")
  path = File.join(path,"Repository")
  if File.file?(path)
    seq = open(path)
    repo = seq.gets(nil)
    seq.close

    puts mo + "," + repo.split("/")[0]
    
  end
}
Comment 4 sparcmoz 2004-12-09 10:26:27 UTC
*** Issue 22882 has been marked as a duplicate of this issue. ***
Comment 5 ooo 2004-12-09 10:56:32 UTC
In CVS there is the CVSROOT directory with the file ``modules'' in which all
modules and aliases are listed. I guess it would be easier on the long term and
more fail safe and always up-to-date to use that to dynamically generate a
project/module list, instead of using a snapshot list of directories you need to
have checked out.
Comment 6 sparcmoz 2004-12-10 04:18:17 UTC
Maybe the modules could be listed in another tab behind projects, with a 
similar filter and link to the project. I have found this page very useful

http://www.openoffice.org/servlets/ProjectList?type=Projects&mode=TopLevel

Comment 7 bluedwarf 2004-12-13 16:12:51 UTC
Created attachment 20482 [details]
Proposal: new "Modules" page
Comment 8 bluedwarf 2004-12-13 16:15:19 UTC
er, thanks for your insight.

The new "Modules" page was created automatically by ruby script with
CVSROOT/modules. After this, if new modules are created, fill in "Description"
and "Project in charge" on this page manually.

Martin, would you upload this file?
Comment 9 Martin Hollmichel 2004-12-20 13:50:33 UTC
new page is uploaded now, thank you for the work.
Comment 10 bluedwarf 2004-12-20 14:26:06 UTC
Thanks, Martin. I confirmed.
Comment 11 foskey 2004-12-22 21:19:51 UTC
Completed.