Issue 38613 - parent directory locked after file closed
Summary: parent directory locked after file closed
Status: CLOSED DUPLICATE of issue 21747
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m62
Hardware: All Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2004-12-08 05:20 UTC by mfedyk
Modified: 2005-03-10 09:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mfedyk 2004-12-08 05:20:15 UTC
1. Open file in directory
2. Close file
3. Rename file's parent directory

The directory is still locked, and an error is given.

4. (There are no OOo 1.9.m62 windows open) Close Quickstarter
5. Directory rename is successful
Comment 1 erzielin 2005-02-15 18:38:17 UTC
Duplicated/Confirmed with build 680m77.

1. Opened an Impress document in c:\folder1. There were no other OpenOffice.Org
application windows open.
2. Closed Impress document.
3. Attempted to renamed c:\folder1 to c:\folder2, and get an error message:

Title: Error Renaming File or Folder

"Cannot Rename folder1: It is being used by another person or progam.
Close any programs that might be using the file and try again."

Is this the Autorecovery process holding some sort of connection to the file open?

Windows XP Pro SP2
Hotfixes to 2/05
Java JRE 1.4.2_06

Comment 2 erzielin 2005-02-16 00:15:52 UTC
Additional update from erzielin's previous entry today. The parent directory is
still locked several hours later, even though all instances of OOo applications
were closed with the exception of the Quickstarter.
Comment 3 erzielin 2005-02-18 19:20:09 UTC
This appears to be a rather serious problem, since the OOo application is
interfering with the file system even when there are no documents open (i.e.
they have been closed).
Comment 4 flibby05 2005-03-10 09:29:58 UTC
closing as duplicate

*** This issue has been marked as a duplicate of 21747 ***
Comment 5 flibby05 2005-03-10 09:30:14 UTC
.