Issue 3875 - Multiple Cell Select Doesn't Work Unless Two Or More Cells Are Initially Selected
Summary: Multiple Cell Select Doesn't Work Unless Two Or More Cells Are Initially Sele...
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 642
Hardware: All All
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
: 10897 15752 15949 16685 19133 21217 25793 25975 27794 34815 45589 50018 (view as issue list)
Depends on:
Blocks: 35121
  Show dependency tree
 
Reported: 2002-04-05 01:10 UTC by Unknown
Modified: 2013-08-07 15:15 UTC (History)
5 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Proposed patch (SRC680_m44) (5.33 KB, patch)
2004-07-20 04:38 UTC, kyoshida
no flags Details | Diff
Revised patch (SRC680_m44) (6.15 KB, patch)
2004-07-26 03:47 UTC, kyoshida
no flags Details | Diff
Another patch (5.45 KB, text/plain)
2004-07-27 02:35 UTC, kyoshida
no flags Details
Back-ported to OpenOffice_1_1_3 (5.27 KB, patch)
2004-10-07 02:37 UTC, kyoshida
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-04-05 01:10:00 UTC
When trying to select multiple cells via the CTRL key, you must first select 
two or more cells, then CTRL, then deselect any unwanted cells that were 
required to begin multiple select.
Comment 1 peter.junge 2002-04-05 09:05:45 UTC
Hi Steven,
you're right, selecting a single cell in OOoCalc is a little bit
difficult in the moment. Easiest way is click -> shift+click. Changing
this is in discussion.
Reassigning it to Falko.
Best regards, Peter   
Comment 2 peter.junge 2003-04-24 12:16:03 UTC
*** Issue 10897 has been marked as a duplicate of this issue. ***
Comment 3 oc 2003-06-25 11:12:31 UTC
*** Issue 15949 has been marked as a duplicate of this issue. ***
Comment 4 oc 2003-06-25 11:14:43 UTC
*** Issue 15752 has been marked as a duplicate of this issue. ***
Comment 5 oc 2003-07-22 15:39:45 UTC
*** Issue 16685 has been marked as a duplicate of this issue. ***
Comment 6 frank 2003-09-08 10:14:50 UTC
*** Issue 19133 has been marked as a duplicate of this issue. ***
Comment 7 mrsoto 2003-09-08 15:12:25 UTC
A possible option may be clicking in a cell and keep pushed button for
a while, for example 3 sec.
Came from comments in issue 19133
Comment 8 falko.tesch 2003-09-11 15:03:29 UTC
Yes, I agree we should change our selection behaviour in Calc.
Comment 9 falko.tesch 2003-09-11 15:04:06 UTC
Started
Comment 10 daniel.rentz 2003-10-15 11:54:20 UTC
*** Issue 21217 has been marked as a duplicate of this issue. ***
Comment 11 bettina.haberer 2003-12-05 17:55:17 UTC
Hello Niklas, please give approval for this evaluated OO.o 2.0 flagged
issue. 
If you confirm with the target OO.o 2.0, then please keep it on your
owner (or the owner of the concerning developer) for implementation.
In case you want this issue for 'OOo Later', then please reset the
target milestone. If you decline the issue finally, please set the
resolution to 'Wontfix' (but do not close). In case of 'OOo Later' or
'Wontfix' please reset it on Bettina's owner. Thank you.
Comment 12 frank 2004-02-23 14:16:59 UTC
*** Issue 25793 has been marked as a duplicate of this issue. ***
Comment 13 geofffarrell 2004-02-24 09:38:34 UTC
If you're going to implement a change to the selection behaviour in Calc, then
please don't introduce an impediment as suggested by mrsoto.  Waiting 3 seconds
every time you want to make a multiple selection would very quickly become
tedious.  Please, just make *pressing the Ctrl key* add more cells to the
present selection, single cell or otherwise.
Comment 14 frank 2004-03-01 10:10:19 UTC
*** Issue 25975 has been marked as a duplicate of this issue. ***
Comment 15 frank 2004-04-15 10:26:18 UTC
*** Issue 27794 has been marked as a duplicate of this issue. ***
Comment 16 Martin Hollmichel 2004-05-28 15:01:19 UTC
according to the announcement on releases
(http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=7503) this issue
will be re-targeted to OOo Later.
Comment 17 pavel 2004-07-04 19:41:30 UTC
nn: is this that hard to implement that it has to be postponed to OOoLater? This is:

- very old
- very inconvenient
- repeatedly reported

Can you please say if you can implement it for 2.0?
Comment 18 kyoshida 2004-07-20 04:38:52 UTC
Created attachment 16594 [details]
Proposed patch (SRC680_m44)
Comment 19 kyoshida 2004-07-20 04:41:52 UTC
kohei->Calc team: Please evaluate the above patch to see if it's acceptable. 
Thanks.

Kohei
Comment 20 kyoshida 2004-07-21 17:47:42 UTC
I should set the status to "STARTED" since I'm already working on this...  BTW,
that patch still needs some work.
Comment 21 kyoshida 2004-07-26 03:47:22 UTC
Created attachment 16758 [details]
Revised patch (SRC680_m44)
Comment 22 kyoshida 2004-07-26 03:52:44 UTC
The above patch differs from the previous one in the following points:

1. Fixes mis-behavior when Ctrl-Arrow is pressed.
2. Provides the same behavior when in add-selection mode via Shift-F8
3. Ctrl-clicking on the same cell also highlights that cell.

kohei->nn: Please evaluate this patch when you have time.  Thanks.

Kohei
Comment 23 kyoshida 2004-07-26 16:11:58 UTC
The patched rejected after nn's review.  Don't use it.  There will be another one.
Comment 24 kyoshida 2004-07-27 02:35:45 UTC
Created attachment 16786 [details]
Another patch
Comment 25 niklas.nebel 2004-07-27 14:50:04 UTC
It's committed to CWS "dr20" (with slightly shortened names).
Comment 26 niklas.nebel 2004-08-24 08:45:21 UTC
reopening to reassign
Comment 27 niklas.nebel 2004-08-24 08:45:41 UTC
reassigning to QA for verification
Comment 28 oc 2004-08-25 15:36:41 UTC
reset resolution to fixed
Comment 29 oc 2004-08-25 15:37:40 UTC
verified in internal build cws_dr20
Comment 30 frank 2004-09-30 08:44:53 UTC
*** Issue 34815 has been marked as a duplicate of this issue. ***
Comment 31 oc 2004-10-04 14:50:35 UTC
fix available in current master OOo1.9.54
Comment 32 kyoshida 2004-10-07 02:37:47 UTC
Created attachment 18189 [details]
Back-ported to OpenOffice_1_1_3
Comment 33 frank 2004-10-07 07:54:05 UTC
Hi Kohei,

please open a new Issue and attach your patch to this, as OOo1.1.3 is currently
available, the target should be OOo1.1.4.

Frank
Comment 34 kyoshida 2004-10-07 14:16:33 UTC
Hi Frank, I've created i35121 for the mentioned patch as you suggested.

Kohei
Comment 35 frank 2005-03-21 08:01:45 UTC
*** Issue 45589 has been marked as a duplicate of this issue. ***
Comment 36 jnoreiko 2005-03-21 09:36:59 UTC
I think the basic selection behaviour is at fault.

There seem to be two types of selection for a cell: with the border showing and
with the cell body highlighted. Only the second allows dragging.

I'm not sure this is the best way to go, as it's quite confusing to understand
the behaviour, even for advanced users.

I know that 'do it like MS Office does' is a dirty word around here ;) but if
you look at Excel you'll see that instead of two kinds of selection behaviour,
they have different areas of the cell perform different actions: to drag a cell
you click on the border rather than the body of the cell.
Comment 37 daniel.rentz 2005-05-30 10:43:47 UTC
*** Issue 50018 has been marked as a duplicate of this issue. ***
Comment 38 frank 2006-04-07 10:33:11 UTC
*** Issue 45589 has been marked as a duplicate of this issue. ***