Issue 38880 - MathType equations cause doc load to fail
Summary: MathType equations cause doc load to fail
Status: CLOSED DUPLICATE of issue 35546
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: 680m62
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL: http://www.users.on.net/~fitzhood/mat...
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-13 06:16 UTC by mr_than
Modified: 2013-08-07 14:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
doc for first listed error - lots of mathtype 5 objects (227.00 KB, application/msword)
2004-12-13 06:18 UTC, mr_than
no flags Details
second doc - less fewer mathtype 5 objects different error (65.50 KB, application/msword)
2004-12-13 06:18 UTC, mr_than
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mr_than 2004-12-13 06:16:09 UTC
This word doc contains MathType 5 equations. It loads in 1.13 and 1.1.4 RC 1
with no problems (takes quite a while but loads). In 1.9.62 it only gets part 
way through loading and a MathType error is thrown: "Too many windows open.".
The file is locked by the soffice.exe process and I have to kill it in order to
delete the file. The doc is fine in word 2002.

I'm opening them all for conversion to PDF via a Java UNO Bridge. The following
java sxception is thrown:

java.lang.Exception: XComponent at file:///C:/OOo/Course Profile PDF
assets/partc_cp.doc failed to load
	at convert.DocumentCreator.doc2Pdf(DocumentCreator.java:574)
	at convert.CourseProfileGenerator.<init>(CourseProfileGenerator.java:227)
	at convert.CourseProfileGenerator.main(CourseProfileGenerator.java:63)

-----
Several other word docs with MathType 5 equations (no where near as many as
above) also fail to load in 1.9.62, no error is shown in the application though.
The following stacktrace applies to
http://www.users.on.net/~fitzhood/mathtype/partc_cp_maths.doc. Again the file is
left locked and the soffice process has to killed before it can be removed.

com.sun.star.task.ErrorCodeIOException: 
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
	at
com.sun.star.lib.uno.protocols.urp.Unmarshal.readExceptionValue(Unmarshal.java:464)
	at com.sun.star.lib.uno.protocols.urp.Unmarshal.readAnyValue(Unmarshal.java:400)
	at com.sun.star.lib.uno.protocols.urp.Unmarshal.readValue(Unmarshal.java:208)
	at com.sun.star.lib.uno.protocols.urp.urp.readReply(urp.java:190)
	at com.sun.star.lib.uno.protocols.urp.urp.readMessage(urp.java:312)
	at com.sun.star.lib.uno.protocols.urp.urp.readMessage(urp.java:624)
	at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge$MessageDispatcher.invoke(java_remote_bridge.java:185)
	at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge$MessageDispatcher.run(java_remote_bridge.java:170)
Comment 1 mr_than 2004-12-13 06:18:02 UTC
Created attachment 20454 [details]
doc for first listed error - lots of mathtype 5 objects
Comment 2 mr_than 2004-12-13 06:18:37 UTC
Created attachment 20455 [details]
second doc - less fewer mathtype 5 objects different error
Comment 3 michael.ruess 2004-12-14 12:25:45 UTC
Known problem. See issue 35546.

*** This issue has been marked as a duplicate of 35546 ***
Comment 4 michael.ruess 2004-12-14 12:26:37 UTC
Closed.