Issue 39083 - Hyperlink not imported in TableOfContents cause Writer only generates frome outline paragraphs
Summary: Hyperlink not imported in TableOfContents cause Writer only generates frome o...
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 680m55
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-16 04:59 UTC by bianhui
Modified: 2013-08-07 14:38 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The content is wrong when open this file. (38.00 KB, application/msword)
2004-12-16 05:01 UTC, bianhui
no flags Details
a small hack in txmsrt.cxx (571 bytes, application/octet-stream)
2005-01-04 05:43 UTC, gyang
no flags Details
new2.foot, a flat xml file (10.78 KB, application/octet-stream)
2005-01-04 05:43 UTC, gyang
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bianhui 2004-12-16 04:59:40 UTC
Hello:
  Open the file in the attachment. The content is wrong.


  Version : 680(Build:8811)
Comment 1 bianhui 2004-12-16 05:01:47 UTC
Created attachment 20560 [details]
The content is wrong when open this file.
Comment 2 mdxonefour 2004-12-16 13:13:54 UTC
In a src680 m65 build 8850 the content looks fine.
Comment 3 michael.ruess 2004-12-16 13:58:00 UTC
Yes, agree with MD. This has already been fixed.
Comment 4 michael.ruess 2004-12-16 13:59:56 UTC
Closed. Checked with 680m65.
Comment 5 wind.li 2004-12-20 11:51:32 UTC
In the bugdoc, only the level 1 hyperlinks are imported, the other links are lost.
Comment 6 michael.ruess 2004-12-23 16:11:22 UTC
MRU->OS: looking with m66 on that file hsows, that the Hyperlink options seem to
be imported correctly in the TOC, but they are not shown in the document (in the
second level)
Comment 7 Oliver Specht 2005-01-03 13:42:23 UTC
The paragraph style Heading 2 is not part of the outline numbering. It is
included into the TOC because it is configured under 'additional styles' 
Hyperlinks can only be generated for outlines.
Comment 8 michael.ruess 2005-01-03 15:07:29 UTC
In this case, this issue should be reopened and marked as "enhancement" for
further dicision on new interoperability "features".
Comment 9 gyang 2005-01-04 05:42:14 UTC
Yes, The paragraph style heading 2 falls into the category TOX_TEMPLATE instead
of TOX_OUTLINELEVEL. With a hack in file sw\source\core\tox\txmsrt.cxx. The
hyperlinks of style "heading 2" in TOC can be produced. (please see the attached
patch)  But clicking on the paragraph 2 hyperlink, it still can't jump to
paragraph 2 because the praragraph 2 is  imported as  "text:p" with style
"heading 2" instead of "text:h" so the staroffice cann't jump to paragraph 2.
In addition, to reproduce the bug file in word, following the below steps:
1) new a empty doc in word
2) insert tile1 with style "heading 1", title 1.1 and title1.2 with style
"heading  2"
3) move the cursor to title1, select format ->"style and formatting" from  the
main menu. In the "style and formatting" pane, click the drop-down box to modify
the style "heading 1".
4) Then in the popup tabdialog "modify the style" choose the format->numbering,
then associate a numbering style with the style "heading 1". Done.

PS: if the bug file can be imported as the attached file new2.foot then the
problem might be solved.
Comment 10 gyang 2005-01-04 05:43:07 UTC
Created attachment 21024 [details]
a small hack in txmsrt.cxx
Comment 11 gyang 2005-01-04 05:43:56 UTC
Created attachment 21025 [details]
new2.foot, a flat xml file
Comment 12 Oliver Specht 2005-01-06 06:38:27 UTC
Reopened, changed to enhancement, target set to OOo Later
Comment 13 Oliver Specht 2005-01-06 06:38:52 UTC
.
Comment 14 Oliver Specht 2005-01-06 08:14:08 UTC
*** Issue 39835 has been marked as a duplicate of this issue. ***
Comment 15 grsingleton 2005-01-06 13:37:03 UTC
This is a dup. Closing

*** This issue has been marked as a duplicate of 12228 ***
Comment 16 grsingleton 2005-01-06 13:46:00 UTC
.
Comment 17 michael.ruess 2005-01-06 13:55:56 UTC
No, it is not a duplicate of 12228. This here is about a lack in the TOC
handling, and not in losing something in the file format (as described in issue
12228).
Comment 18 grsingleton 2005-01-06 14:12:56 UTC
I disagree but will monitor progress.
Comment 19 grsingleton 2005-01-06 16:07:46 UTC
On hte off cahnce this may pertain, I imported
http://documentation.openoffice.org/manuals/OOo1.x.x/user_guide.sxw inot 1.9m67
to test whether or not hyperlinking works as in 1.1.x. It does; however, I found
that first you have to save the file as .odt and then rebuild the TOC. Once done
the TOC works as expected. This loss of info on import was what was addressed in
12228 and it is obviously corrected.
Comment 20 lohmaier 2005-01-16 21:46:28 UTC
If this is about the "Toc cannot hyperlink entries that are added using
additional styles", then this is a duplicate of issue 3356 and should be closed
as such.

It this one is about changing the import, then keep this one :-)
Comment 21 grsingleton 2005-01-16 21:55:30 UTC
Import is the operative word here. Please keep open. And yes it is related,
however distantly, to http://www.openoffice.org/issues/show_bug.cgi?id=3356
Comment 22 cno 2007-10-01 14:55:56 UTC
Does this issue's type has to be set to a Patch?
(see post from gyang Tue Jan 4 05:43:07 +0000 2005 )?
Comment 23 michael.ruess 2007-10-09 14:37:27 UTC
MRU->OS: could you pls evaluate the proposed patch ? Thanks a lot!
Comment 24 Oliver Specht 2007-10-31 10:40:34 UTC
As written in the description the patch is a hack that doesn't work. As there is
no type "Hack" for issues I change the type to Defect again. Target changed back
to later.
Comment 25 cno 2010-06-03 11:23:48 UTC
works OK in 3.2.1
(probably due to the work done on outline numbering and non list styles)
  > set to fixed
Comment 26 cno 2010-06-07 14:28:20 UTC
and closed