Issue 3952 - In word the height of a space for layout purposes appears to be 0
Summary: In word the height of a space for layout purposes appears to be 0
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 642
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 5125 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-04-10 11:26 UTC by caolanm
Modified: 2013-08-07 14:40 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
reference example (13.00 KB, application/octet-stream)
2002-04-10 11:26 UTC, caolanm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description caolanm 2002-04-10 11:26:23 UTC
In word the height of a space for layout purposes appears to be 0, i.e. a 72
point space adds no height to a line. Example and explanation attached. Would be
nice if we could support this...
Comment 1 caolanm 2002-04-10 11:26:44 UTC
Created attachment 1349 [details]
reference example
Comment 2 andreas.martens 2002-04-19 10:41:00 UTC
If we implement this older writer documents could change their outfit.
Do we want this or do we need another compatibility flag "Ignore blank
height"?
Comment 3 frank.meies 2002-05-22 07:32:56 UTC
*** Issue 5125 has been marked as a duplicate of this issue. ***
Comment 4 falko.tesch 2003-10-01 14:44:50 UTC
FT->AMA: Well, now you are the owner of this :o)
My 2 cts.: Add a compatibility flag and do not change our file format.
Comment 5 andreas.martens 2003-10-02 10:46:22 UTC
Yes, this would improve our interoperability.
Comment 6 andreas.martens 2004-01-29 10:46:18 UTC
Okay, it would be nice. Priority is 4, first we've to do some more common tasks.
Comment 7 frank.meies 2004-02-02 07:57:24 UTC
.
Comment 8 Martin Hollmichel 2004-05-28 14:57:29 UTC
according to the announcement on releases
(http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=7503) this issue
will be re-targeted to OOo Later.
Comment 9 frank.meies 2005-03-14 10:55:49 UTC
FME: The same holds for tabs.
Comment 10 frank.meies 2005-08-31 12:52:19 UTC
We need a compatibility flag for this. We should consider the problem for OOo
2.0.2. For OOo2.0.1 we don't plan such UI change. For OOo2.0.2 we'll discuss
this problem again.
=> Retarget to OOo2.0.2
Comment 11 frank.meies 2005-08-31 12:53:46 UTC
.
Comment 12 frank.meies 2005-11-30 07:36:05 UTC
.
Comment 13 frank.meies 2006-01-09 09:47:05 UTC
FME: Changed target.
Comment 14 frank.meies 2006-03-03 09:58:18 UTC
FME: Fixed in cws swqbf57:

/cvs/sw/sw/source/ui/uno/SwXDocumentSettings.cxx,v  <--  SwXDocumentSettings.cxx

new revision: 1.46.166.1; previous revision: 1.46

/cvs/sw/sw/source/filter/ww8/ww8par.cxx,v  <--  ww8par.cxx

new revision: 1.163.6.1; previous revision: 1.163

/cvs/sw/sw/source/filter/rtf/swparrtf.cxx,v  <--  swparrtf.cxx

new revision: 1.56.6.1; previous revision: 1.56

/cvs/sw/sw/source/core/text/atrstck.cxx,v  <--  atrstck.cxx

new revision: 1.21.240.1; previous revision: 1.21

/cvs/sw/sw/source/core/inc/atrhndl.hxx,v  <--  atrhndl.hxx

new revision: 1.13.240.1; previous revision: 1.13

/cvs/sw/sw/source/core/doc/docnew.cxx,v  <--  docnew.cxx

new revision: 1.57.166.2; previous revision: 1.57.166.1

/cvs/sw/sw/inc/doc.hxx,v  <--  doc.hxx

new revision: 1.112.166.1; previous revision: 1.112

/cvs/sw/sw/source/core/text/porlay.cxx,v  <--  porlay.cxx

new revision: 1.58.98.3; previous revision: 1.58.98.2
Comment 15 frank.meies 2006-03-10 11:05:31 UTC
FME: Ready for QA.

re-open issue and reassign to mru@openoffice.org
Comment 16 frank.meies 2006-03-10 11:05:35 UTC
reassign to mru@openoffice.org
Comment 17 frank.meies 2006-03-10 11:05:39 UTC
reset resolution to FIXED
Comment 18 michael.ruess 2006-03-14 14:59:27 UTC
Verified in CWS swqbf57.
Comment 19 michael.ruess 2006-03-31 14:11:12 UTC
Checked in build 680m161.