Issue 39748 - HTML import/export: full HTML 4.01 features
Summary: HTML import/export: full HTML 4.01 features
Status: CLOSED DUPLICATE of issue 19666
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-01 00:10 UTC by jackbassv
Modified: 2019-02-03 16:58 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jackbassv 2005-01-01 00:10:46 UTC
I'm very disappointed with the options in the HTML section. It offers IE, 
Netscape (sic) and HTML 3.2.
Surely HTML 4.1 should be an option by now, preferably with all tags in lower 
case for XML compatibility.
Can we also have an option to import HTML without modifying the tags?
Currently Writer changes any existing tags to HTML 3, even if the source is 
HTML4 - This is V annoying.
Comment 1 michael.ruess 2005-01-03 09:50:46 UTC
MRU->ES: pls evaluate this "RFE".
Comment 2 eric.savary 2005-01-03 11:10:40 UTC
Reassigned
Comment 3 tongro 2005-03-20 17:22:16 UTC
More recent browsers such as Mozilla, Mozilla Firefox, and Opera should also be
included in the list, even if it's only for the sake of showing that IE is "just
one of many browsers". It would also show that OOo is totally up-to-date.
Comment 4 tongro 2005-03-20 17:36:08 UTC
I must say that I personally hate the HTML that OOo produces. I understand that
the reason why there is so much formatting code inserted is to maintain the
appearance of the page, but to me layout is usually not nearly as important as
code clarity and efficiency. And, am I right in thinking that HTML formatting
tags are now deprecated in favour of CSS?

It would be nice to see another option for HTML export - minimal formatting.
Comment 5 jackbassv 2005-03-20 19:45:44 UTC
You're correct, tongro.

As of HTML 4.0, (almost) all tag extentions are depreciated.  Formating should 
be contained within CSS, either inline or as a seperate file (.css).

As for Firefox and Opera selection, they're not really needed.  Both use the w3c 
HTML 4 standard, without any stupid extentions, the only major differences are:-
Opera doesn't support img transparancy properly and Firefox has problems with z-
index=-1.

(I'm an Opera 8 beta tester :-))
Comment 6 stp 2008-10-04 17:48:16 UTC
confirmed
Comment 7 White Phoenix 2013-09-12 23:29:23 UTC
Just so no one has to hunt up the other bug to read my comment:

Choosing between the different versions of HTML seems to me more important than which browser they should be formatted to. Actually the goal is usually to be non-browser specific when creating a web page. Which would seem to fall in line with the open document philosophy.

Also include “strict” and “transitional” versions and now include the latest HTML 5.0 as well.
Comment 8 Peter 2019-02-02 14:19:50 UTC
I merge this into one issue that focuses on the html4 compliant standard.

*** This issue has been marked as a duplicate of issue 19666 ***