Issue 39835 - Cannot hyperlink additional styles in TOC
Summary: Cannot hyperlink additional styles in TOC
Status: CLOSED DUPLICATE of issue 3356
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 1.1.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-03 19:51 UTC by grsingleton
Modified: 2013-08-07 14:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description grsingleton 2005-01-03 19:51:34 UTC
It is not possible to hyperlink additional styles in a Table of Contents or
other index. This was reported in users today. I have confirmed that this so and
believe it is a defect.
Comment 1 grsingleton 2005-01-03 19:52:41 UTC
Added Laurent to cc list
Comment 2 maison.godard 2005-01-03 20:16:50 UTC
Hi 
problem on all 1.1.x versions (Linux) 
even on 1.9.65 
 
Laurent 
Comment 3 grsingleton 2005-01-03 21:26:54 UTC
What is worse it under 1.9m67, one cannot even get what one has in 1.1.x
Comment 4 michael.ruess 2005-01-04 14:11:55 UTC
MRU->ES: this is similar (or even duplicate) to issue 39083. Please clear out
with OS, how to further process this.
Comment 5 grsingleton 2005-01-04 14:20:55 UTC
Not a duplicate. This issue addresses the problem of not being able to hyperlink
additional styles. What is worse, is that m67 will not even accept the addition of 
any additional style. Thus we have a regression.
Comment 6 eric.savary 2005-01-04 23:55:25 UTC
-> grsingleton: Please file another issue for the non considered additional styles.

-> OS: obviously, additional styles have never been able to carry hyperlinks.
Comment 7 grsingleton 2005-01-05 12:59:09 UTC
-> grsingleton: Please file another issue for the non considered additional styles.

Huh? THis is the issue that addresses this problem. You should know that any
undocumented feature is a bug. This issue reports this bug. 

-> OS: obviously, additional styles have never been able to carry hyperlinks.

WHat!?  This is not STATED anywhere. Additional styles should be included and to
NOT include them is a DEFECT.  I repeat, 
Huh? THis is the issue that addresses this problem. You should know that any
undocumented feature is a bug. This issue reports this bug.
Comment 8 maison.godard 2005-01-05 13:35:57 UTC
Hi all 
 
IMHO, the problem is that hyperlinks are handled in "Entries" Tab that only 
deals with outline numberring and not Table of Contents levels which are two 
seprated things 
 
--> make "Entries" concern TOC levels and not only outline numberring 
 
Laurent 
Comment 9 Oliver Specht 2005-01-06 08:14:09 UTC
.


*** This issue has been marked as a duplicate of 39083 ***
Comment 10 grsingleton 2005-01-06 13:09:33 UTC
Re-opened.  THIS IS NOT A DUPLICATE!! This issue addresses a failure of OOo to
deal with hyperlinking additional syles. This bug has nothing to do with 39083.
In fact 39083 should be closed as "will not fix" as the functionality is there
but the OP and apparently others haven't a clue. 

NOW GET THIS FIXED, please, and stop attemtping to close a legitimate issue.
Comment 11 Oliver Specht 2005-01-06 14:19:50 UTC
Please calm down and stop crying.
In this task you initially reported that the Writer is not able to jump to the
'addtional styles' in a TOC
Afterwards you reported that in m67 it's not possible to add addtional styles
anymore. ES asked you to submit an addtional issue for that and you wrote the
following: 
 "Huh? THis is the issue that addresses this problem. You should know that any
 undocumented feature is a bug. This issue reports this bug. " 
which is obviously wrong. BTW - just checked an m67 and it worked.

Issue 39083 is about an imported .doc-file that results in a TOC with
'additional styles' where the hyperlinks are missing. They are missing because
the Writer cannot jump to those paragraphs.

For me these two issues are duplicates.

The issue 12228, that you have set as a duplicate of 39083 is about a save/load
problem where the paragraph style/outline level assignment is lost. I cannot see
the similarity.









Comment 12 grsingleton 2005-01-06 14:52:31 UTC
I suspect that language is the problem.  I stated "It is not possible to
hyperlink additional styles in a Table of Contents or
other index." Where to find jumping. Your statement of "In this task you
initially reported that the Writer is not able to jump to the
'addtional styles' in a TOC" make no sense. Let me explain:

I wnat to hyperlink additional styles regardless of the release I use. That you
cannot is the issue. So in your haste to close you have misread what is stated.
Additional headers SHOULD be able to be hyperlinked in any index. Do you not
agree? On the off chance that you misinterpret the problem again, the abiltiy to
hyperlink ALL index entries, especially in a TOC, is implicit in OOo. 

BTW, 39083 in my estimation is a duplicate of 12228. I looked at the sample
files and believe it is user error in setting up the TOC that is the problem.
Further the problem is solved in releases later than the one the OP used. 

As to similarity of 39083 to 12228, check. 

IU suggest that in your haste you are missing the point.
Comment 13 Oliver Specht 2005-01-06 15:05:34 UTC
In which other index than TOC we have 'additional styles'? 

Comment 14 grsingleton 2005-01-06 15:14:55 UTC
Other than being pendantic, what is your point. The summary explicity states
TOC. Is just that you wish to invalidate the summary info or are you trying to
be insulting? 
Comment 15 pseudo_daoist 2005-01-07 02:47:21 UTC
>In which other index than TOC we have 'additional styles'?

Everything that can be created at ">Insert >Indexes and Tables >Indexes and
Tables >Index/Table >Type and Title >Type _Drop Down Box_"


FWIW, I've had documents which have had up to 50 _different_ styles for the
TOC.[Text had twenty or so different languages in, with different heading levels.]

xan

jonathon
Comment 16 grsingleton 2005-01-07 03:09:21 UTC
Thanks for your insight. However, how does this apply to hyperlinking additional
styles. Please explain.
Comment 17 eric.savary 2005-01-07 15:29:18 UTC
To sum up, 2 problems here:

1) Additinal styles cannot be hyperlinked.
This has never (any release) been possible.
The reason of this missing feature (or concept bug, whatever one may call it...)
has been correctly described by Laurent Godard.
This problem is already addressed by issue 3356 (which is, yes, an enhancement,
because we need to think about and specify a new design of the dialog for this)

2) Since a few builds (approx. m67) additional styles cannot be added to TOCs.
This bug is a regression which is now reported in issue 40135

I close this task as duplicate of issue 3356.

*** This issue has been marked as a duplicate of 3356 ***
Comment 18 eric.savary 2005-01-07 15:30:08 UTC
closed
Comment 19 grsingleton 2005-01-07 16:08:03 UTC
Thanks for the explanation. I will use this to update the user guide. It must be
documented somewhere and the guide is the only thing under my control.
Comment 20 maison.godard 2007-03-28 10:27:38 UTC
what is the status here ?