Issue 39837 - allow to LINK to another database's tables
Summary: allow to LINK to another database's tables
Status: CLOSED DUPLICATE of issue 42464
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-03 20:53 UTC by afore
Modified: 2017-01-01 08:56 UTC (History)
3 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
impress file with horeizontal line problems. (19.32 KB, application/vnd.sun.xml.impress)
2005-10-25 17:30 UTC, afore
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description afore 2005-01-03 20:53:23 UTC
Base is a very nice application, but suffers two major defects.

1. There needs to be a way to LINK to another database, such as a spreadsheet, so 
you can run an append query to an existing table. Example: I have a database with 
a part table. I put in new parts in a spreadsheet as when adding a large # of 
parts, it is much easier for editing, copy/paste, etc. I have 999 resistors where 
the only difference is value, value in the description field, and the value in the 
manufacturer part number. In a spreadsheet, it is very easy to do this without 
entering each individual part and much more accurate. Then I import this into the 
table in the database, presently, postgresql using MSAccess. 

2. There needs to be an ODBC driver for the Base database. Although it is not 
needed for OOo, I have another application that can only access the database 
through ODBC. It is DxDataBook where I can browse parts, click on the part, and 
place the schematic symbol in Viewdraw and annotating the symbol with the 
appropriate data from the database.

Art Fore
Comment 1 Frank Schönheit 2005-01-04 08:25:27 UTC
afore, please read http://qa.openoffice.org/issue_handling/basic_rules.html, in
particular http://qa.openoffice.org/issue_handling/basic_rules.html#one_per_issue.
In this case, I'm not insisting on you submitting a separate issue for the
second part, since it would be rejected, anyway :). As you yourself say, OOo
doesn't need an ODBC driver for dBase, so why should it ship with one? There are
plenty of free ODBC drivers for all platforms we're interested in, so why should
we create Yet Another One?

So what's left is that your first point. I adust the summary accordingly -
thanks for reporting.
Comment 2 marc.neumann 2005-01-04 09:15:02 UTC
Hi, 

for your first part there is a solution in OOo.

- Select all your cells in your spreadsheet
- copy these cells to the clipboard
- select the databse table where you want to append the cells
- choose paste from the context menu of the table
- in the paste dialog enter the table name and choose append.
- click OK

Then your data are apend to the table.

Is this want you are looking for?

Bye Marc
Comment 3 afore 2005-01-04 16:39:35 UTC
I knew about the copy/paste method which is a work-around, but this is much more 
cumbersome than linking to a spreadsheet and running an append query. You are 
much more restricted to the format of the spreadsheet than using the linked 
table metnod. I also find the linked table method to be much faster.

Another use of linked tables is to link to an MRP database, for example Oracle, 
then have your own table of data not normally in an MRP database. You can run a 
query and merge the data so it appears to be one database. This is also used in 
several commercial applications to access specific data for that application.

I other words, OOo Base really needs to have the capability to link tables. That 
is one of MSAcess's strong points.

Art
Comment 4 marc.neumann 2005-01-06 08:16:54 UTC
Hi,

Yes you are right. This would be a nice Feature.

I reassign this issue to User Experience for evaluating.

Bye Marc
Comment 5 afore 2005-10-25 17:30:11 UTC
Created attachment 30822 [details]
impress file with horeizontal line problems.
Comment 6 ibarnard 2006-08-17 08:39:33 UTC
Is this issue not similar to Issue 42465 ?
Comment 7 drewjensen.inbox 2006-08-17 08:46:21 UTC
Actually, it is IMO a duplicate of Issue 42464
Comment 8 irneb 2008-09-16 07:16:07 UTC
Your point 2 can be circumvented by not creating a standard ODB database file,
but rather one that links to a back-end. Simplest way is a set of DBF tables in
a folder, or even an MDB (Access database). Both these have ODBC drivers.

If you also want multiple users to access the data at once, then you'll need to
have something like a client-server backend. Probably something like MySQL.

Your point 1 is definitely a duplicate of Issue 42464, could someone please mark
it as such?
Comment 9 oooforum (fr) 2016-12-31 17:45:00 UTC
According to comment 7 and 8

*** This issue has been marked as a duplicate of issue 42464 ***