Issue 3988 - relax constraint that objects and frames in headers and footers are restricted to vertical limit of header or footer
Summary: relax constraint that objects and frames in headers and footers are restricte...
Status: CLOSED OBSOLETE
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 641
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 2674 3815 5102 5209 5243 6818 7563 9382 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-04-12 02:38 UTC by ez
Modified: 2013-12-04 15:13 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Here's an example Word doc with graphics in header/footer illustrating the problem on import in OO. (178.50 KB, application/msword)
2004-11-30 16:30 UTC, msandersen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ez 2002-04-12 02:38:54 UTC
At present the only elements that are common to all pages (with the same page style) are in the header and footer or a backgrpund graphic 
that is constrained to be within page margins.  It is not possible to include common elements on pages that are outside these areas and are not 
graphics.  For example a watermark across the whole page, "draft printed on 3 March 2001", cannot be automatically updated using text and 
fields and graphics cannot encroach into page margins.  Allowing elements to be anchored to pages in headers and footers would solve this, as 
would the ability to position elements outside a header or footers vertical area in addition to the current ability to do so beyond the horizontal 
area.
Comment 1 caolanm 2002-04-12 09:19:07 UTC
For what its worth, the same difference in design makes impossible
importing documents from word that make use of a similiar design to
this proposal. One where the header/footer graphic layer can be
considered a graphic layer that is underneath the main document
graphic layer. Anything that overflows from the header/footer is shown
under the main doc text.
Comment 2 stefan.baltzer 2002-05-06 11:52:31 UTC
Reassigned to Chrisatian.
Comment 3 prgmgr 2002-09-22 04:15:04 UTC
*** Issue 5209 has been marked as a duplicate of this issue. ***
Comment 4 prgmgr 2002-09-22 04:45:54 UTC
*** Issue 5243 has been marked as a duplicate of this issue. ***
Comment 5 prgmgr 2002-09-22 04:53:47 UTC
*** Issue 5243 has been marked as a duplicate of this issue. ***
Comment 6 prgmgr 2002-09-22 06:55:52 UTC
*** Issue 5102 has been marked as a duplicate of this issue. ***
Comment 7 prgmgr 2002-09-22 16:16:08 UTC
*** Issue 2674 has been marked as a duplicate of this issue. ***
Comment 8 prgmgr 2002-09-23 03:26:50 UTC
*** Issue 6904 has been marked as a duplicate of this issue. ***
Comment 9 prgmgr 2002-09-26 01:43:55 UTC
*** Issue 3815 has been marked as a duplicate of this issue. ***
Comment 10 prgmgr 2002-09-29 00:04:40 UTC
*** Issue 6818 has been marked as a duplicate of this issue. ***
Comment 11 prgmgr 2002-10-21 01:56:35 UTC
*** Issue 7563 has been marked as a duplicate of this issue. ***
Comment 12 prgmgr 2002-11-20 04:01:56 UTC
*** Issue 9382 has been marked as a duplicate of this issue. ***
Comment 13 christian.jansen 2003-03-24 07:46:37 UTC
Reassiged to Bettina.
Comment 14 guido.pinkernell 2003-11-06 13:34:17 UTC
*** Issue 8664 has been marked as a duplicate of this issue. ***
Comment 15 msandersen 2004-11-30 16:30:31 UTC
Created attachment 19918 [details]
Here's an example Word doc with graphics in header/footer illustrating the problem on import in OO.
Comment 16 msandersen 2004-11-30 17:41:57 UTC
In addition to the above attachment: It contains graphics inserted in the Header
and Footer in Word. When you first insert it, the Header/Footer expands to the
height of the graphic, but once it is set to the Front (still behind the text),
it floats free of the size of the header/footer. Thus it can be used to create
watermarks on every page.

However in OO, the imported graphics are squished to the size of the Header and
Footer. 

Apart from fixing the floating of graphics in the header/footer behind the text,
there is another more elegant and far-reaching solution that will solve a number
of related issues, such as alternating styles for headers/footers on opposing
pages (eg books) with perhaps a centered chapter title and page number on the outer:
The addition of Master Pages akin to page layout programs like Quark, as I've
described in issue 18275 , where any graphic/frame/header/footer can be set for
left or right pages at will, possibly with alternate Master Pages for different
sections (eg different section title in footer, different watermark, say chapter
number). This also allows for more precise positioning of graphics/frames (eg
slanted frame with "Draft 1" in bold text), and not arbitrarily constrained by
page margins. This would give OO a marked feature advantage over Word.

Note: The test doc displays a couple of other defects in Word imports, namely:
1. an image set to bleed off the page (outside the margins) wil be repositioned
INSIDE the margins. Once the anchor is reset to Page, it is fixed, but should
have been done on import.
2. Same for frames with text on the 2nd page.
3. The embedded EPS graphic disappears.

I'm sure the first two at least have been reported, simply mentioning in case
people wonder. I'll do a search for the latter.
Comment 17 stp 2007-08-13 18:49:25 UTC
WorksForMe in 2.2. Please confirm.
Comment 18 bettina.haberer 2010-05-21 14:42:20 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 19 Regina Henschel 2013-12-04 15:13:44 UTC
In the meantime an option "Follow text flow" has been implemented, so that the user can decide whether a free move should be possible or not.