Issue 39984 - Regression: File-->Open of tif yields terribly slow response
Summary: Regression: File-->Open of tif yields terribly slow response
Status: ACCEPTED
Alias: None
Product: Draw
Classification: Application
Component: viewing (show other issues)
Version: 680m65
Hardware: All All
: P3 Trivial (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-05 18:47 UTC by drichard
Modified: 2013-02-07 21:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
offending .tif image. So slow in draw the program cannot be used, crashes for some. (160.61 KB, image/tiff)
2005-01-05 18:48 UTC, drichard
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drichard 2005-01-05 18:47:26 UTC
Our beta program for 2.0 has started.  I had a report and confirmed that the
attached file when opened with File--Open attempts to load into the Draw
program.    The reporter had OOo crash completely, in my testing it was
painfully slow on remote display and not usable.  Even after image loaded,
scroll bars were inactive because it was just too slow.  However, if you do a
File->New Document and then insert this same graphic into the body of a fresh
message it loads and scrolls just fine.
Comment 1 drichard 2005-01-05 18:48:40 UTC
Created attachment 21113 [details]
offending .tif image.  So slow in draw the program cannot be used, crashes for some.
Comment 2 wolframgarten 2005-01-06 08:06:05 UTC
Large bitmap with transparency. Can you please tell me a little bit about your
hardware? (RAM, CPU) Thanks in advance.
Comment 3 drichard 2005-01-06 14:19:21 UTC
Thin clients are being used, Power-PC based 66Mhz NCD Explora 451s.  This same
.tif image on OOo 1.1.2 and 1.1.3 work fine:  on those older versions it loads
and refreshes almost instantly and scrollbars work fine.  Problems are only on
2.0 builds.

How can I help?
Comment 4 wolframgarten 2005-01-06 15:27:27 UTC
Thanks for the hint with the regression from 1.1.3 . Performance has been lost.
The crash I cannot reproduce but the slow behaviour.
Reassigned to Christian.
Comment 5 clippka 2005-01-06 16:40:34 UTC
Thorsten, please have a look
Comment 6 thb 2005-01-06 17:10:53 UTC
Okay, will check that. Changed title, to match reproducible behaviour.
Comment 7 ooo 2005-01-17 16:45:56 UTC
Setting target to OOo 2.0.1 due to resource constraints
Comment 8 thb 2005-05-27 23:49:40 UTC
Retargeted, due to resource constraints.
Comment 9 thb 2012-07-13 20:48:05 UTC
Reset to default bug assignee.