Issue 39992 - Autodetection of language of typed text
Summary: Autodetection of language of typed text
Status: CLOSED DUPLICATE of issue 73173
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 680m65
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: frank.loehmann
QA Contact: issues@sw
URL:
Keywords:
: 39991 40598 45913 (view as issue list)
Depends on:
Blocks:
 
Reported: 2005-01-06 01:16 UTC by alex_rus
Modified: 2013-08-07 14:42 UTC (History)
6 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description alex_rus 2005-01-06 01:16:30 UTC
Hi,
 is it possible to implement autodetection of text language, as if paste or
write two language text especially very long (40 and above pages) it's very time
consuming to assign language to each paragraph.

Alexander
Comment 1 eric.savary 2005-01-06 02:07:57 UTC
ES->SBA: Please, have a look. I guess, the answer is: "use paragraph styles!!!"
Comment 2 eric.savary 2005-01-06 02:08:49 UTC
*** Issue 39991 has been marked as a duplicate of this issue. ***
Comment 3 jigal 2005-01-10 23:47:12 UTC
This feature is present in current versions of Word. I've tested it and I must 
say that it is very handy for multi-language documents. Behaviour in Word:

* Option "Automatic" in set language dialogue
* Current language is initially used for spellchecker.
* If sentence is 'finished' (either by punctuation and whitespace or by moving 
the cursor), the sentence is checked in all installed languages and the 
language which produced the least number of errors will be chosen. In case of 
multiple winners the current language and the default language will have 
priority.
* Autocorrection (and exceptions) is taken into account (abbreviation or end of 
sentence?)
Comment 4 stefan.baltzer 2005-01-19 09:09:40 UTC
SBA: Reassigned to requirements.
Comment 5 comomolo 2006-08-10 03:22:14 UTC
Seems easy to implement and gives so much relief to multi-language writers!!!
Comment 6 comomolo 2006-08-10 03:26:34 UTC
And it'st not only useful for multi-language docuements. I woudl say it fits
multi-language writers. One document is writen in English, the other one in
Spanish, a new one in French. The writer doesn't have to care about changing
language for each of these documents, the software will do the job.

(Since I use Word as Outlook editor and since I write many emails a day to
different countries in different languages, this is a joy to use!!!)
Comment 8 cbhihe 2006-08-17 22:42:01 UTC
*** Issue 39992 has been confirmed by votes. ***
Comment 9 stefan.baltzer 2006-10-27 17:25:15 UTC
SBA->FL: As discussed, please proceed.
Comment 10 stefan.baltzer 2006-10-27 17:31:57 UTC
*** Issue 40598 has been marked as a duplicate of this issue. ***
Comment 11 stefan.baltzer 2006-10-27 17:32:30 UTC
SBA: Put TL on c/c. Set target OOo 2.2
Comment 12 Martin Hollmichel 2007-01-15 12:00:50 UTC
set target to 2.3 since we already missed the deadline for 2.2.
Comment 13 Mathias_Bauer 2007-01-17 20:49:16 UTC
Our current plans to support language detection are smarter. We have implemented
a tool that can guess languages based on the mentioned textcat - it works great
at least for complete paragraphs. It avoids the possibly huge memory (and time!)
consumption of loading all available dictionaries and use them.

We will embed this tool into a complete concept including the things mentioned
in issue 1034 and its duplicates.
Comment 14 Mathias_Bauer 2007-01-17 20:53:51 UTC
*** Issue 45913 has been marked as a duplicate of this issue. ***
Comment 15 thomas.lange 2007-01-18 09:49:00 UTC
Duplicte to issue 73173.
Since I was not aware of this issue I created a new one for langauge guessing
and since I already used the other ID for committing files I'll set this one as
duplicate and keep the new one.

*** This issue has been marked as a duplicate of 73173 ***
Comment 16 Mathias_Bauer 2007-01-18 14:30:36 UTC
closing