Issue 40204 - Plain Paste (wrongly) shift down cells before pasting
Summary: Plain Paste (wrongly) shift down cells before pasting
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1.3
Hardware: PC Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
Keywords: oooqa
: 42008 46349 (view as issue list)
Depends on:
Reported: 2005-01-08 17:07 UTC by christopheg
Modified: 2005-03-31 08:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description christopheg 2005-01-08 17:07:37 UTC
Title says it all. Plain Paste used to replace contents of target selection (and
still does it with OOo Calc 1.1.4 for Windows), on my Linux Debian Box 1.1.3
insert copied cells (shifting down target cells and all cells below) instead of
replacing contents of target cells.

This is very bad behavior because in a spreadsheet data is usually organised by
row/columns. Say one column for item, one column for price. If you copy a price
cell because two items have the same price you do not wish to shift down all the
price columns (getting all the prices wrong below insertion point).

This behavior could be handy when copying entire rows (shift down) of entire
columns (shift right) because inserting complete rows or columns does not break
line semantic. But for individual cells its usually evil (only exception : when
you are moving around unrelated zones of cells of the same width, say cells for
different geographic zones, but yet such goal could be better achieved copying
full rows).

I put in in P1 because Calc will be pretty useless until corrected : too
dangerous !!! I do not want to release a broken price list or such because of a
split second of inattention.

The following links point to threads on mailing list or forums related to this

I reported it too on the user ML (I thought there was an option to change
behavior I had missed) under the title :

[users] Calc: cut/copy/paste of cells incoherent and dangerous, change proposal

(not yet appearing on Internet Archive, so no link sorry).
Comment 1 grsingleton 2005-01-08 19:01:47 UTC
Added to cc list
Comment 2 claudionieder 2005-01-09 14:55:59 UTC
I can confirm this on Debian Sarge (+unstable) with OpenOffice 1.1.3.

It annoys me too. Such a change in behaviour - if there are people who want the
new behaviour - should have been made configurable. E.g. have the Paste
Special... dialog have a "make this behaviour the default" button.
Comment 3 thackert 2005-01-09 15:36:00 UTC
Have you tried to log this error in the Debian-OOo bugtracker? They are using a
different version (more correctly: The Debian people are using patches for a
better Debian-compatibility) of OOo, so I think you should report it in their
bugtracker ... ;)
Comment 4 claudionieder 2005-01-09 16:00:51 UTC
Me not, but somebody else did:
Comment 5 frank 2005-01-10 09:56:59 UTC

checked it on different Linux distributions and can't reproduce using OOo builds.

Seems to be a Debian problem.

Also Prio 1 is much to high. Corrected this.

Comment 6 frank 2005-01-10 09:57:28 UTC
closed wfm
Comment 7 bobharvey 2005-02-02 23:44:47 UTC suggests this is not a
Debian issue.

I tried it on Mandrake 10.1 and saw the reported behaviour
Comment 8 smmilton 2005-02-03 20:39:46 UTC
This is a confirmed problem on two different FC3 boxes also.

This is new behavior since this last update.  Ctrl-C/Ctrl-V functionality is
pretty core stuff.  Changing the way it behaves is a MAJOR productivity
inhibitor.    This should be reopened and fixed, or at the very least discuss
workarounds for those afflicted.
Comment 9 smmilton 2005-02-03 20:43:08 UTC
This bug has been confirmed on the RedHat Bugzilla site.
Comment 10 fa 2005-02-04 00:53:23 UTC
This "feature" was due to a patch introduced by Novell into ooo-build sources,
and is NOT part of the distributed by  Its purely
a local addition to ooo-build (which is used as the basis of Debian, Novell,
Suse, and Red Hat) and has already been removed from those sources.

Again, this isn't not an issue but a local vendor one for those
who use ooo-build.
Comment 11 frank 2005-02-04 08:17:37 UTC
*** Issue 42008 has been marked as a duplicate of this issue. ***
Comment 12 frank 2005-03-31 08:01:13 UTC
*** Issue 46349 has been marked as a duplicate of this issue. ***