Issue 40728 - Hyperlink in index table is incompletely generated
Summary: Hyperlink in index table is incompletely generated
Status: CLOSED DUPLICATE of issue 3356
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 680m69
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-01-15 14:32 UTC by paul_cazottes
Modified: 2005-01-15 23:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The .odt file, with all the text erased (13.99 KB, application/vnd.sun.xml.writer)
2005-01-15 14:33 UTC, paul_cazottes
no flags Details
Screenshot (123.14 KB, image/jpeg)
2005-01-15 14:34 UTC, paul_cazottes
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description paul_cazottes 2005-01-15 14:32:07 UTC
I've a document with an index table, in which i would like to enable     
hyperlink, for exemple for a PDF export.   
     
When generating the index table, OpenOffice.org Writer only create an     
hyperlink for contents 3 (See attached IndexHyperlink.odt and screenshot).  
When I try to modify the table (table property), preview shows all contents 
hyperlinked.    
    
I had the same problem with OO.org 1.9m65 on Windows XP. With OpenOffice 1.1.3 
(official builds) on Debian Sarge, hyperlink doesn't work at all.    
I had this problem with a .doc imported document, and with a fresh file.  
It seems linked with #29858 ("Wrong hyperlinks in index" on OpenOffice.org 
1.1.1) 
    
Best Regards    
Paul Cazottes
Comment 1 paul_cazottes 2005-01-15 14:33:33 UTC
Created attachment 21548 [details]
The .odt file, with all the text erased
Comment 2 paul_cazottes 2005-01-15 14:34:37 UTC
Created attachment 21549 [details]
Screenshot
Comment 3 lohmaier 2005-01-15 23:16:00 UTC
reproducible but duplicate.

OOo cannot hyperlink entries that are added to the toc using "additional styles"

Define your level1/2 Headings in Tools|Outline numbering as such and remove your
headings from the additional styles of the TOC.
This way you will have a hyperlinked TOC.

*** This issue has been marked as a duplicate of 3356 ***
Comment 4 lohmaier 2005-01-15 23:19:41 UTC
closing duplicate.