Issue 41049 - File truncation on load
Summary: File truncation on load
Status: CLOSED DUPLICATE of issue 17171
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.1.2
Hardware: PC Linux, all
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2005-01-20 18:43 UTC by fbillington
Modified: 2005-01-20 19:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description fbillington 2005-01-20 18:43:11 UTC
I have a 269K streaming text RTF file that HAS NO HARD RETURNS in it.  When
doing File | Open, OOo Writer truncates this file on load about 1/3 of the way
through.

I did a search and replace in the original app that created it (WordPerfect 8
for Windows) replacing [CHAPTER] with [HardReturn][CHAPTER] and then saved it
back to disk as an RTF file.  OO Writer was happy with this loading all 50 chapters.

OOo Writer 1.1.3 for Windows on Win98 SE behaves the same way.

OOo Writer appears to be unable to handle large text files unbroken by any hard
returns.  I've used files of this nature for years in WordPerfect.

I'm a newbie to both OO and Linux, and this is my first bug/issue report.  I
read the instructions first.  I hope this is suitable.

I can be contacted at d.m.s@shaw.ca

Thanks for a truly great product.  It is this product that is allowing me to
move away from Windows.  I am grateful.

Frank Billington
Calgary, Canada.
Comment 1 fbillington 2005-01-20 18:54:33 UTC
The 269K RTF file that I used to test this is english-language.  It is a book
with 50 chapters in it.  Words are separated by spaces as is normal for a book.
 The only thing that appears to cause a failure to load is the absence of hard
returns in this file.

Frank Billington
d.m.s@shaw.ca
Comment 2 lohmaier 2005-01-20 19:19:42 UTC
duplicate.

*** This issue has been marked as a duplicate of 17171 ***
Comment 3 lohmaier 2005-01-20 19:21:52 UTC
closing duplicate.