Issue 41296 - Wizard project contains java methods > jdk 1.3.1
Summary: Wizard project contains java methods > jdk 1.3.1
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 680m73
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.0
Assignee: marc.neumann
QA Contact: issues@installation
URL:
Keywords:
: 45989 (view as issue list)
Depends on:
Blocks: 42145
  Show dependency tree
 
Reported: 2005-01-25 16:02 UTC by berend.cornelius
Modified: 2005-08-17 11:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Document with attached Basic macro (7.12 KB, application/vnd.sun.xml.writer)
2005-02-28 08:52 UTC, berend.cornelius
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description berend.cornelius 2005-01-25 16:02:29 UTC
The following methods in the wizards project are not compliant to jdk 1.3.1:

common\Helper.java:294: getTimeInMillis() has protected access in java.util.Calendar
            docNullTime = calendar.getTimeInMillis();
common\Helper.java:322: getTimeInMillis() has protected access in java.util.Calendar
            long date1 = calendar.getTimeInMillis();
common\Helper.java:339: setTimeInMillis(long) has protected access in java.util.
Calendar
            calendar.setTimeInMillis( javaTimeInMillis ) ;
common\Helper.java:341: getTimeInMillis() has protected access in java.util.Cale
ndar
            long date1 = calendar.getTimeInMillis();
                                 ^
common\JavaTools.java:360: decode(java.lang.String) in java.net.URLDecoder canno
t be applied to (java.lang.String,java.lang.String)
                        URLPath = URLDecoder.decode(URLPath, "UTF-8");
                                            ^
common\JavaTools.java:371: setTimeInMillis(long) has protected access in java.ut
il.Calendar
                cal.setTimeInMillis(timeMillis);
                   ^
common\JavaTools.java:387: getTimeInMillis() has protected access in java.util.C
alendar
                return cal.getTimeInMillis();
                          ^
common\Configuration.java:145: valueOf(java.lang.String) in java.lang.Boolean ca
nnot be applied to (boolean)
                set(Boolean.valueOf(value), name, parent);
                           ^
ui\event\AbstractListener.java:122: cannot resolve symbol

These occurrences have to be replaced by other compatible calls. I had a
discussion with sb about the Url conversion issue and he advised to make use of
the  service "com.sun.star.uri.udk,translatetoexternal/translatetointernal
methods to convert to and from JavaUrl notation. The other occurrences should be
fixable by the class set  that jdk1.3 offers
Comment 1 berend.cornelius 2005-01-26 12:04:29 UTC
BC: Especially in the tutorial executor and creator are that many calls that I
think this module should be removed from the build list
Comment 2 berend.cornelius 2005-01-26 14:52:15 UTC
Another occurrence is:
CGDocument.java:277: cannot resolve symbol
symbol  : method split  (java.lang.String)
location: class java.lang.String
        String[] parts = media.split("_");
                              ^
1 error
...

        WWD_General.java        WWD_Startup.java        WWHID.java
StoppedByUserException.java:91: cannot resolve symbol
symbol  : constructor Exception  (java.lang.Throwable)
location: class java.lang.Exception
                super(arg0);
                ^
StoppedByUserException.java:100: cannot resolve symbol
symbol  : constructor Exception  (java.lang.String,java.lang.Throwable)
location: class java.lang.Exception
                super(arg0, arg1);
                ^
2 errors
Comment 3 berend.cornelius 2005-02-04 15:32:42 UTC
.
Comment 4 berend.cornelius 2005-02-28 08:52:50 UTC
Created attachment 23100 [details]
Document with attached Basic macro
Comment 5 berend.cornelius 2005-02-28 09:07:17 UTC
BC: As you can see from the Basic Macro of the  attached document  the method
translatetoExternal  of the interface
"com.sun.star.uri.XExternalUriReferenceTranslator" does not work properly which
detains me from completely fixing this bug.
BC->SB: Is it Ok to set priority to P3, because
1. Building under JDK13 is a major issue and
2. I fixed already a major part of the  bug myself.
Comment 6 berend.cornelius 2005-02-28 09:07:56 UTC
.
Comment 7 eric.bachard 2005-03-03 22:53:52 UTC
Hi,

1) I have exactly the same break on Linux PPC with sdk1.3.1 (We only have this
jdk on Linux PPC ...) and problems (at least) with :

Helper.java and JavaTools.java in wizards/com/suun/star/common

setTimeInMillis() has protected access...  6 or 7 times

decode(java.lang.String) in java.net.URLDecoder cannot be applied to 
( java.lang.String,java.lang.String)   

strange...

2) The attached doc looks empty for me... tested with OOo1.9.77 on Linux PPC and
on Linux Intel with 1.9.73 .

I think this is probably nothing important to do, but I'm a complete dummy with
java. May you put an example of what is to do please ?


Regards,
eric bachard






Comment 8 Stephan Bergmann 2005-03-07 13:33:33 UTC
SB->BC:  As discussed, a replacement for the code that currently uses URLDecoder
could use the (as of now private) method
com.sun.star.lib.util.NativeLibraryLoader.mapUrlToFile in jurt.jar, which
converts an (external/Java) file java.net.URL into a java.io.File.  ABI is going
to export that method as part of some other issue, anyway.

SB->ABI:  Please provide BC with the details when that method will be exported
(issue id), and pass this issue back to BC.
Comment 9 andreas.bille 2005-03-11 13:48:49 UTC
i44810 on fwkfinal2
Comment 10 eric.bachard 2005-03-23 16:51:07 UTC
ericb -> abi 

Thank you, I test immediatly  fwkfinal2 cws

Regards,
eric bachard

Comment 11 eric.bachard 2005-03-23 21:41:49 UTC
With fwkfinal2, qadevOOo build breaks (see attachment), so wizards cannot be
verified, because build later. Waiting, perhaps qadev22 can help me...

To be continued

-- 
eric bachard
Comment 12 eric.bachard 2005-03-23 23:34:38 UTC
I have canceled the attachment, because useless here.

After some trother tries, qadevOOo builds fine with qadev22, and I can test with
fwkfinal2. But wizards failed to build with : m88/m87 extras19 opensymbol1 gcj3
cws's

What I don't understand is why wizards is not in the modules list for fwkfinal2
 (nor fwkfinal up to 4 neither..? )

Note : wizards directory removed for every cws test.
Errors are always : getTimeInMillis and around....

Thank you very much for your help.

Regards,
eric bachard


Comment 13 berend.cornelius 2005-03-29 08:51:01 UTC
As described above you have to build the wizards project with a Java
RuntimeEnvironment >= 1.4. Otherwise the build breaks in the wizards module.
Comment 14 berend.cornelius 2005-05-25 20:08:12 UTC
*** Issue 45989 has been marked as a duplicate of this issue. ***
Comment 15 berend.cornelius 2005-06-13 12:10:23 UTC
Fixed in qwizardsbfooo20
Comment 16 berend.cornelius 2005-06-28 16:04:22 UTC
BC: Fixed in qwizardsbfooo20:
BC->TV: Please test with special regards to  File OpenDialogs and Calendar
functions (Agenda Wizard and LetterWizard and WebWizard.

re-open issue and reassign to hi@openoffice.org
Comment 17 berend.cornelius 2005-06-28 16:04:30 UTC
reassign to hi@openoffice.org
Comment 18 berend.cornelius 2005-06-28 16:04:37 UTC
reset resolution to FIXED
Comment 19 h.ilter 2005-06-29 09:14:30 UTC
.

re-open issue and reassign to bc@openoffice.org
Comment 20 h.ilter 2005-06-29 09:14:37 UTC
reassign to bc@openoffice.org
Comment 21 h.ilter 2005-06-29 09:14:51 UTC
reset resolution to FIXED
Comment 22 berend.cornelius 2005-06-29 17:02:22 UTC
.

re-open issue and reassign to msc@openoffice.org
Comment 23 berend.cornelius 2005-06-29 17:02:27 UTC
reassign to msc@openoffice.org
Comment 24 berend.cornelius 2005-06-29 17:02:33 UTC
reset resolution to FIXED
Comment 25 marc.neumann 2005-06-30 09:22:13 UTC
verified in cws, as far as the mention java code is not available anymore.
However I can't test if the build with 1.3.1 is successful, because I have no
build environment.
Comment 26 maho.nakata 2005-07-16 12:27:58 UTC
msc:
could you please tell me in which cws you have fixed.
I can test with JDK1.3+RedHat9(GNU/Linux) environment.

thanks!
Comment 27 maho.nakata 2005-07-26 00:47:16 UTC
msc:
build verified with m119, GNU/Linux (Redhat9), JDK 1.3.1_16 of SUN.
many thanks!
(BTW: could you please telling me in which cws you worked?)
Comment 28 marc.neumann 2005-08-17 11:58:38 UTC
close this issue because it's fixed in m119