Issue 41511 - JRE warning goes into infinite loop
Summary: JRE warning goes into infinite loop
Status: CLOSED DUPLICATE of issue 37020
Alias: None
Product: General
Classification: Code
Component: scripting (show other issues)
Version: 680m74
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 2.0
Assignee: tomaisoc
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-28 08:55 UTC by ralphie
Modified: 2010-11-11 03:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ralphie 2005-01-28 08:55:26 UTC
To reproduce:

1. Uninstall/remove JRE or do not install it in the first place
2. Open Word Processor component
3. Select Tools->Macros->Run Macro
4. The warning "OpenOffice.org requires a Java runtime environment 
   (JRE) to perform this task. Please install a JRE and restart 
   OpenOffice.org. [OK]" appears.
5. Klick [OK]
6. The exactly same warning reappears, ad infinitum. The only way
   leave this loop is to kill the application.

Thanks!
Comment 1 noel.power 2005-01-28 10:06:06 UTC
tom, I suspect there was already a bug against this if so can you dig it out and
mark this as dup?
Comment 2 tomaisoc 2005-01-28 11:15:15 UTC
This is a duplicate of 37020. Unfortunately if Java is disabled, an error
message will be popped up every time OOo tries to instantiate a Java
component, see issue 37020 for more information on why this happens.

If you keep clicking OK in the warning dialog eventually it goes away.

*** This issue has been marked as a duplicate of 37020 ***
Comment 3 Mathias_Bauer 2005-03-31 16:07:23 UTC
Only a closed issue is a good issue. :-)
Comment 4 crewotclasour 2010-11-11 03:48:12 UTC
Created attachment 74187