Issue 41746 - Relative font sizes get lost when saving (File gets unreadable)
Summary: Relative font sizes get lost when saving (File gets unreadable)
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 680m75
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-31 16:30 UTC by stefan.baltzer
Modified: 2013-08-07 14:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Bugdoc (6.48 KB, application/vnd.oasis.opendocument.text)
2005-01-31 16:34 UTC, stefan.baltzer
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description stefan.baltzer 2005-01-31 16:30:09 UTC
To reproduce:
Load bugdoc (SXW file, created with StarOffice 7PP4)
Save as (.sxw or .odt), OK
File-Reload
-> The font size in the first row of the first table shrinked to 2pt. (Looks
like data loss)
-> In styles "Plus_4_pt" and "Minus_4_pt", the relative font sizes are lost and
the fonts have a size of 995%. Thus the file now has 50+ pages and is totally
unreadable.

Note: This worked in 680m71 and is broken at least since 680m73.
Comment 1 stefan.baltzer 2005-01-31 16:34:46 UTC
Created attachment 22041 [details]
Bugdoc
Comment 2 openoffice 2005-01-31 18:34:38 UTC
dvo: I have a fix, but I need to discuss with the engineer who broke this (with
another bugfix) to see whether such a fix is acceptable, and what else might be
affected. Also, I need a decision on which CWS to use. (I need only module svx.)
Comment 3 openoffice 2005-01-31 18:40:55 UTC
dvo: Actually, further analysis of the, ermm, conflicting bugfix (i4279) shows
that my fix will almost certainly re-create THAT problem. In either case the
problem should be solvable, but I will need some help.
Comment 4 openoffice 2005-02-02 12:42:31 UTC
dvo: Fixed, by removing the fix for #i4279# . (CWS swqbetterbeta)

Affected files:
svx/inc/fhgtitem.hxx
svx/source/dialog/chardlg.cxx
svx/source/items/textitem.cxx
sw/source/core/doc/fmtcol.cxx

(svtools/inc/poolitem.hxx contains an additional definition for #i4279#, which I
left in, as this does not hurt any.)
Comment 5 openoffice 2005-02-02 13:57:43 UTC
reopen for QA
Comment 6 openoffice 2005-02-02 13:59:17 UTC
dvo->sba: Please test.

Please also thoroughly test related functionality to prevent further
regressions. Thanks.
Comment 7 openoffice 2005-02-02 14:01:11 UTC
set fixed
Comment 8 stefan.baltzer 2005-02-02 17:18:47 UTC
SBA: Verified in CWS swqbetterbeta.
Comment 9 stefan.baltzer 2005-02-09 13:54:29 UTC
SBA: OK in 680m78 (Build 8874).