Issue 42036 - Updates to contribution page.
Summary: Updates to contribution page.
Status: CLOSED FIXED
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Website general issues (show other issues)
Version: current
Hardware: Sun All
: P3 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: scarr
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-04 09:04 UTC by dcarrera
Modified: 2013-02-08 20:58 UTC (History)
5 users (show)

See Also:
Issue Type: TASK
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description dcarrera 2005-02-04 09:04:15 UTC
The Contribution page needs some updates:

http://www.openoffice.org/contributing.html

1) The Writing page needs to be updated. I wrote an update here:

http://website.openoffice.org/tryouts/dcarrera/contributing/en/writing.html

I only changed a few things, but this page is clearer and easier to read. More
importantly, it is more accurate. It better reflects who is doing what right now.

2) The 'Programming' page is obsolete after the creation of the ToDo's page. The
"Programming" link should now point to:

http://development.openoffice.org/todo.html

3) Usability and visual improvements.

The names given to looks look akward and out of place. The original page I made
had links fit reasonably well so that the longer strings were on the same column
(right) and the shorter ones on one column (left).

At a minimum, the following changes should happen:

 * Replace "Art" by "Graphics and Art".
 * Replace "OpenOffice.org in Your Language" by "Language Communities".
 * Replace "Bug Squashing/Quality Assurance (QA)" by either "Bug Squashing" or
"Quality Assurance" but not both.


These will make the page feel more balanced again.

Daniel.
Comment 1 lsuarezpotts 2005-02-05 00:37:02 UTC
accepting and will implement.
Thanks for filing the issue :-). 

Louis
Comment 2 stx123 2005-02-05 14:31:23 UTC
Hi, I would prefer, if the links to the guides (Getting Started, Writer Guide,
...) would point to the location of the finalized work at the OpenOffice.org
main site. The contribution page points out where a contributor could offer
help, but we should reference the finalized documentation.
Greetings, Stefan
Comment 3 dcarrera 2005-02-05 14:41:13 UTC
No, that doesn't make sense. This is the *contribution* page. It should point to
where the work is being done. That's the whole purpose of making this page.

Making those links go to the published files would be like making the
"Programming" go to where you put the final binaries. No. You send the
contributor to the place where the work is being done, and the user to the place
where the "stable" version is.

Daniel.
Comment 4 stx123 2005-02-05 17:13:58 UTC
I agree regarding the links like "is run at ..." or "send an email to ..."
should point to the work environment for (potential) contributors. Nevertheless
I expect enough "users" to consider the documents we point to as final. I would
like to avoid misunderstandings. So let's avoid the links to work in progress as
it is on the current published page.
Comment 5 dcarrera 2005-02-05 17:44:12 UTC
If someone thinks "I want to contribute" and clicks on the "contribution" link,
and then click on the "Write" link, they will expect to go to the place where
they can contribute by writing. Not to a page that doesn't let them contribute
or write.

If the page was intended for users to locate documentation, it should point to
finishe documentation. Since the page is for would-be contributors to locate a
place to contribute, the link should send them to the place where they can
contribute.

Best,
Daniel.
Comment 6 dcarrera 2005-02-06 19:05:50 UTC
Stefan,

Feel free to edit the contribute/writing page as you like. Though I don't think
you'll find alternate URLs where those links will make sense. Two of them don't
have published versions at all ("Getting Started" and "Database"). All the other
links would point to the same page, and one of the names would be wrong
("Impress Guide" vs "Impress Quickstart").

Maybe it'd be better to change the wording "[the guide] is divided into..." and
make it "our current projects are:"

Would that work?

Regardless. Please make the changes that you think are appropriate. I'm keen on
seeing the page updated soon.

Best,
Daniel.
Comment 7 lsuarezpotts 2005-02-18 20:07:45 UTC
sorry, didn't see this in my queue
am working on  it...
Comment 8 dcarrera 2005-02-18 20:10:12 UTC
Thank you.
Comment 9 dcarrera 2005-02-19 03:13:53 UTC
Uhm... how long is this expected to take? Updating the page should take no more
than 10 minutes. I've done all the work already, you just copy and paste.

Daniel.
Comment 10 dcarrera 2005-02-19 05:26:40 UTC
Alright, just to illustrate how utterly trivial changing this page is, I just
made another one with the "controversial" links removed. I timed myself. The
process took 2min. The page is here:

http://website.openoffice.org/tryouts/dcarrera/contributing/en/writing2.html

Most of that time was spent doing the SSH tunnle, CVS login and CVS commit. The
actual edit was edit was about 20 seconds.

Can we please have the page updated?

Cheers,
Daniel.
Comment 11 lsuarezpotts 2005-02-22 00:24:07 UTC
I'll get to this tomorrow or so.  The thing is, I want to replace the "development" tab as well.

-louis
Comment 12 dcarrera 2005-02-22 00:27:23 UTC
Louis, this has nothing to do with the development tab. If you try to pile
together the tiniest change into a major site overhaul you'll never get anything
done. In this instance we're just changing a few links and some minor
explanations to make the text clearer. That should be a no-brainer.

Daniel.
Comment 13 lsuarezpotts 2005-02-22 02:28:30 UTC
adding gerry to the cc to review the documentation links.

Gerry: the Writing component (in this case, writing2) points people working on files to authors@user-
faq. That's fine with me but I want to confirm the structure with you.

Louis
Comment 14 lsuarezpotts 2005-02-22 02:37:49 UTC
As to changing the programming link to todos.  At the moment, until the development/todo.html page 
is updated to include JCA information, I'd rather keep the programming link. The contributing/
programming page is pretty good :-), and I don't think it's obsolete.  

Made the other changes recommended to contributing.html.

louis
Comment 15 dcarrera 2005-02-22 02:37:55 UTC
Actually, there are several links, one for each documentation type. Each of
those points to wherever that documentation is being developed. In particular,
for FAQs it points to dev@documentation and for "documentation in your language"
it points to the Native-Lang website. I did this to the best of my knowledge. I
would be happy for Gerry to correct any link I got wrong.

Cheers,
Daniel.
Comment 16 dcarrera 2005-02-25 21:51:59 UTC
Okay, no response from Gerry. Can we take it to mean that everything is cool?

Here's another thought: Just change the page today. If issues arrise later, JUST
FIX THEM. It's not hard. It's just a link. No biggie. It should take less than 3
weeks to update some links.

Cheers,
Daniel.
Comment 17 grsingleton 2005-02-25 23:36:39 UTC
No it's not cool. You know that I have been busy with a family crisis. You just
have to wait. 
Comment 18 dcarrera 2005-02-25 23:46:20 UTC
Actually, I didn't know that. I don't read most emails at the documentation
project list (or any given list for that matter). I get more emails than I can
handle.

I hope things get better for you.

Cheers,
Daniel.
Comment 19 grsingleton 2005-02-26 00:22:28 UTC
Scott please do this review of the links. I cannot at the moment and Daniel is 
anxious.
Comment 20 scarr 2005-02-26 01:38:05 UTC
I see a couple problems with this update.  

FAQ - There is no mention of the user-faq project.  Is it dead?  I thought CPH
was keeping it updated.

Tutorials and How To - There is no mention of the Documentation Project Task List.

I believe we should still reference the doc project as a possible contribution
avenue.  I don't want to lose options that are available currently.
Comment 21 dcarrera 2005-02-26 01:54:08 UTC
I don't know about the user-faq project. I don't follow the FAQs. But I think
it's fair to say that most of the *activity* is at documentation, and that's
what really matters.

I just fixed the Tutorials/Howto section (I think). If you'd like to rewrite it,
by all means. Just tell me what to put down.

Cheers,
Daniel.
Comment 22 scarr 2005-02-26 02:01:46 UTC
I have an email in to CPH to see how the User-Faq project is going.  

We can go ahead and change the page for the moment with the understanding that
we may need to change it again once CPH gets in touch with us.

http://website.openoffice.org/tryouts/dcarrera/contributing/en/writing2.html

Louis, Please go ahead and make the changes to put this page in place.
Comment 23 grsingleton 2006-02-25 13:55:24 UTC
Needs updating either to wiki or merge needs to be completed. Assigning to Scott.
Comment 24 stx123 2011-03-23 16:10:21 UTC
Reset QA Contact to new default
Comment 25 Raphael Bircher 2013-02-08 20:58:08 UTC
Old issue about the old contribution page. Last entry is six years ago. It's no longer needed. so close the issue.