Issue 42694 - tsv (tab seprated values) files cannot be opened in scalc
Summary: tsv (tab seprated values) files cannot be opened in scalc
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 1.1.4
Hardware: PC All
: P2 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-13 17:39 UTC by amimarty
Modified: 2010-06-30 12:00 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
test file with tab seprated values. (60 bytes, text/tsv)
2005-02-13 17:40 UTC, amimarty
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amimarty 2005-02-13 17:39:05 UTC
A tsv file extension file can not be forced to open in scalc.
This has been tried on OOO 1.1.2, 1.1.4 and also in the latest 1.9.x build of
openoffice.

I have created a flat file with the following data separated by tabs

test      test     test      test

named the file test.tsv and when u associate the tsv file extension with scalc,
it always openes up in writer.

Comparative behaviour in Microsoft office is once I associate the file with
excel, the file openes up in excel not in word.
The problem was noticed in Windows 2000, Windows XP ( SP1), WIndows XP (SP2) and
fedora core 3.

If i rename the file extension to csv the file opens up in scalc as it should.

The problem was noticed because Oracle Applications exports the files from its
interface with a .tsv file extension, and openoffice was being evaluated for
installation instead of Microsoft Office.

This happens even if I open scalc and the use file --> open to open the test.tsv
file, it opens up in writer.

There seems to be no way to force scalc to open this file.
Let me know if there are any additional details required.
Comment 1 amimarty 2005-02-13 17:40:36 UTC
Created attachment 22564 [details]
test file with tab seprated values.
Comment 2 frank 2005-02-13 22:06:03 UTC
Hi,

not a bug of OOo. tsv is not a known file extension to OOo even if you assign it
to Calc.

To open such file without renaming it to CSV just select the Filter to use. It's
Test-CSV. 

This behaviour is correct as the file open dialog for OOo isn't Application
dependend but Office wide, therefore a not known file with text content will
open in Writer as this is the app. use dfor text.

Frank 
Comment 3 frank 2005-02-13 22:06:20 UTC
closed invalid
Comment 4 frank 2005-02-15 15:44:32 UTC
Hi,

I can't help you with it, but maybe the StarOffice support from Sun has a
solution. You nay try the following URL http://www.support-central.de/office ,
click on your country and search for 'Per Incident eMail Support'.

Sorry for no better reply.

Frank
Comment 5 smoesmoesmoe 2010-06-28 14:04:00 UTC
Please cross-check with bug 69830, with Linux OOo calc 3.2 I just also ran into
this issue: opening a .tsv file opened OOo writer, not another instance of calc.
Not to recognise .tsv as tab separated values _is_ a bug IMHO. And if you think
differently here, then allow opening it in calc by some other means that is not
an import into an existing document.