Issue 43114 - 1.1.4 fails print with copies
Summary: 1.1.4 fails print with copies
Status: CLOSED DUPLICATE of issue 22304
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 1.1.4
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@gsl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-18 22:26 UTC by dansaintandre
Modified: 2005-06-24 13:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description dansaintandre 2005-02-18 22:26:06 UTC
Symptom:
    Given a multiple page document in any of the applications, select PRINT then
set COPIES as two or more and enable COLLATE.  The desire would be to get a
several sets of pages suitable for binding or stapling.  Select your printer,
and visit the printer's ADVANCED or similar page.  The copy-count remains one(1)
regardless of what you requested from the top level print dialog.
     If you try to set multiple copies in the printer ADVANCED dialog, you get N
times N copies as N times page one, N times page two etc.  If you set one(1)
copy in the basic dialog and N copies in the printer ADVANCED dialog, you get
the same N times page one behavior.

Analysis:
     It does not matter whether you request the print from calc or draw or
present or write.
     This was working at some point prior to 1.1.4.  I did the update and now it
no longer works.
Comment 1 christof.pintaske 2005-02-21 10:10:58 UTC
cp->hi: please have a look and try to reproduce
Comment 2 strada 2005-03-18 09:44:45 UTC
- issue occurs also after 1.1.4 (2.0beta)
- I think it is related to issue 22304
- another aspect:
* at printing any document set copies to more than one (take something high to
test it, e.g. 1000) and select collate
* after clicking ok, OOo will generate X times (e.g. 1000 times) the
instructions for the printers, resulting in huge data being transmitted to the
printer which takes first a lot of time to transmit and second results in a very
long ripping-time (the time the printer translates the data in his own language
before he may print the document). You may fortunately cancel this process.
* this is not only but especially a problem an bigger machines where you print
many copies of documents (printing with copy-machines)
* it doesn't depend of the size of the document (one or more pages) nor of the
installed printer
Comment 3 h.ilter 2005-05-27 11:42:39 UTC
HI->dansaintandre: Which OS you use? If it is Linux, do you use cups?
Comment 4 h.ilter 2005-06-24 13:34:34 UTC
Double to i22304

*** This issue has been marked as a duplicate of 22304 ***
Comment 5 h.ilter 2005-06-24 13:35:11 UTC
.