Issue 43504 - tell desktop we use gnome-vfs
Summary: tell desktop we use gnome-vfs
Status: CLOSED WONT_FIX
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: 680m79
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: nospam4obr
QA Contact: issues@gsl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-24 20:59 UTC by mmeeks
Modified: 2007-03-26 14:59 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mmeeks 2005-02-24 20:59:38 UTC
It seems the .applications file we install doesn't mention that we support the
Gnome VFS & that we can handle URIs on the command-line - which will hinder us
from getting used for more interesting / remote content I think.

--- sysui/desktop/mimetypes/openoffice.applications     21 Jan 2005 11:18:09
-0000      1.5
+++ sysui/desktop/mimetypes/openoffice.applications     24 Feb 2005 20:57:29 -0000
@@ -2,5 +2,6 @@ openoffice
        command=openoffice
        name=%PRODUCTNAME
        can_open_multiple_files=true
-       expects_uris=false
+       expects_uris=true
+       uses_gnomevfs=true
        requires_terminal=false

HTH
Comment 1 christof.pintaske 2005-02-28 15:14:32 UTC
cp->obr: isn't this duplicate to some of yours ? 
Comment 2 nospam4obr 2005-03-01 07:29:12 UTC
Yep, there is #i19175#, which I am about to shift back to target 2.0. 

I did not know the "uses_gnomevfs" key. Since which release of GNOME is this
available ?
Comment 3 nospam4obr 2005-03-02 13:45:54 UTC
Seems like uses_gnomevfs is present since GNOME 2.0.3 & 2.2. 

*** This issue has been marked as a duplicate of 19175 ***
Comment 4 nospam4obr 2005-03-02 13:47:16 UTC
Closing.
Comment 5 kendy 2006-08-02 15:09:03 UTC
Reopening - we still have this patch in ooo-build ;-)  Please, does this patch 
still make sense, or not?  (I guess that yes.)  Issue 19175 speaks about 
incompatibility of ftp: URIs; is it sorted out, please?
Comment 6 nospam4obr 2006-08-04 11:50:06 UTC
I haven't checked recently. However, since gnome-vfs/nautilus is not RFC
compliant here, this has to change on the GNOME side. Replacing:

< supported_uri_schemes=file,http,https,smb
with
> uses_gnomevfs=true

would then have to be done gnome-version dependant.

What specific uri scheme are you missing through the current solution (beside ftp) ?
Comment 7 nospam4obr 2006-08-23 15:08:42 UTC
Sorry, but even if that bug in nautilus has been fixed in the meantime, the
patch is not acceptable as is: we would have to check the nautilus version
during installation or duplicate the deskop-intergration packages, so that
opening file from ftp shares (by copying the file locally) does not break for
older versions.
Comment 8 philipp.lohmann 2007-01-26 16:57:44 UTC
what's up with this issue ? please integrate or close
Comment 9 nospam4obr 2007-01-29 09:31:22 UTC
Changing issue type as patch is not acceptable as is.
Comment 10 nospam4obr 2007-03-21 09:48:00 UTC
I recently noticed that GNOME 2.16 seems to have moved to .desktop files for
associating mime types with applications. Does this mean this issue is obsolete
anyway ? Would like to know before I investigate in whether the original reason
for not accepting the patch still exists.
Comment 11 nospam4obr 2007-03-26 14:59:57 UTC
GNOME 2.18 deprecates all functions in gnome-vfs-application-registry.c in favor
of gnome-vfs-mime-handlers.c, but no sign of "uses_gnomevfs" in the latter =>
closed.