Issue 43819 - Format Style Catalog NOT Working
Summary: Format Style Catalog NOT Working
Status: CLOSED DUPLICATE of issue 4679
Alias: None
Product: Calc
Classification: Application
Component: formatting (show other issues)
Version: OOo 1.0.3
Hardware: PC Windows 2000
: P4 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-01 19:50 UTC by rostrow
Modified: 2005-03-23 10:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rostrow 2005-03-01 19:50:13 UTC
In OpenOffice Calc v1.1.3 the Format/Style Catalog dialog box does not work
correctly. I can create custom styles with the New button but the Modify or
Delete buttons don't work. I can't modify or delete my newly created custom
styles (or any of the built-in styles). It doesn't make any difference if the
new custom styles are applied (in use) or not. The same problem exists in all my
calc files. I thought when I first tried the Style Catalog feature it worked ok
but I cannot confirm this. I can never go back and review my new custom styles
since the Modify button does absolutely nothing (the button depresses but no new
window appears).

I have also tried using the Format/Stylist/Cell Styles dialog box right-clicking
on a custum style, in the list, to bring up a context window and choosing Modify
or Delete. Both of these commands don't work either.
Comment 1 rostrow 2005-03-02 04:33:11 UTC
The problem is caused by Tools/Protect/Document/Sheet. Whenever a sheet is
protected (in my case without a password) in a document the Modify or Delete
buttons in the Format/Style Catalog dialog box are still active but they don't
do anything. These buttons should be disabled if they are not suppose to work
when any sheet or sheets in a document are protected.

The Format/Stylist/Cell Styles context window should also have the Modify and
Delete entries disabled when a sheet is protected (see my original description).
Comment 2 frank 2005-03-02 20:37:29 UTC
Not a Prio 2 task and possibly a double as far as I remember.

Frank
Comment 3 frank 2005-03-23 09:59:52 UTC
double to Issue 4679

*** This issue has been marked as a duplicate of 4679 ***
Comment 4 frank 2005-03-23 10:00:20 UTC
closed double