Issue 43976 - Add installation option to choose market-dominant default file format for platform
Summary: Add installation option to choose market-dominant default file format for pla...
Status: CLOSED DUPLICATE of issue 70753
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0 Beta
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@installation
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-03 11:18 UTC by oharboe
Modified: 2007-05-06 14:42 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description oharboe 2005-03-03 11:18:22 UTC
Which default file format to use is not something that the user generally has
any influence over. 

E.g. under Windows the non-geek user generally has to use Word/Excel 2000 & PDF
formats, because that is what the world expects. 

I would even go as far as suggesting that Word/Excel 2000 should be default file
formats under Windows, unless the user knows what he is doing. 

It only does damage to OpenOffice reputation that a non-geek tells another
non-geek that he can't read a document he received in email because he is using
OpenOffice. 

It would be nice if this could be chosen at install time instead of being hidden
in the options. 

Ximian even had a special version of OpenOffice that made Word formats default.


I believe that this is the users interest, helps OpenOffice and hurts Microsoft.
MS Office worst enemy is MS Office. If the older file-formats are alive and well
and there are no compelling new features that act as an inecentive for upgrades,
then why switch to a newer version of MS Office? 

If all you want are fewer bugs and less money shelled out, then OpenOffice is a
better alternative than the latest & greatest MS Office.

My 2 cents :-)
Comment 1 Olaf Felka 2005-03-03 11:29:00 UTC
I don't see this as a usefull feature: Our open document format provides more
features then the closed source format. I see this as a document-feature
regression. A I don't think that we want to be a clone product.
Comment 2 oharboe 2005-03-03 11:41:35 UTC
>I don't see this as a usefull feature: Our open document format provides more
>features then the closed source format. 

I believe this is 100% true.

>I see this as a document-feature regression. 

Agreed.

However, both these formats(OpenOffice/MS Office) are much, much more powerful
than what the most users will ever need.

Also, it is only the OpenOffice code that can tell that the MS formats are
horrible and feeble. Normally the user has no idea about the pain & suffering
that the OpenOffice team went through. It just works.

>A I don't think that we want to be a clone product.

OpenOffice can do something that Microsoft can never do: create a stable product
that caters for common uses without introducing new formats unless there is a
genunine need for a new format based upon users requirements. 

This is in the users interest, but would be financial suicide for Microsoft.

Comment 3 christof.pintaske 2005-03-03 12:52:38 UTC
please don't add any configuration to the installation. Installation is for
installation not for configuration. There is a different point of control for
configuration.
Comment 4 oharboe 2005-03-03 13:02:10 UTC
>please don't add any configuration to the installation. Installation is for
>installation not for configuration. There is a different point of control for
>configuration.

Agreed.

On the other hand, configuration should be complete when installation is complete.

If the user has to modify options after installations, then strictly speaking
the configuration of these options haven't been moved out of the installation
procedure. 

The installation procedure is not a program, it is the steps that the user must
perform to properly prepare the application for use.

This option would naturally go on the same page that sets up file associations
as drop-down requester(use OpenOffice/Microsoft formats).

Øyvind
Comment 5 christof.pintaske 2005-03-03 13:22:40 UTC
I dare to disagree: configuration has to start when installation is complete.
Configuration has to be user specific (for one user, for a group of users, or
for all users) whereas installation has to be user agnostic (always for all
users). After installation the product is generically usable and can be
configured if desired. Since you must be able to change the configuration at any
time, installation is not the right medium for that or you have to implement it
twice.
Comment 6 oharboe 2005-03-03 13:33:10 UTC
>I dare to disagree: configuration has to start when installation is complete.
>Configuration has to be user specific (for one user, for a group of users, or
>for all users) whereas installation has to be user agnostic (always for all
>users). After installation the product is generically usable and can be
>configured if desired. Since you must be able to change the configuration at any
>time, installation is not the right medium for that or you have to implement it
>twice.

So according to your thinking, file associations should not be configured by the
installer program?

What are the objective criterea that places default file format in the options
menu and file associations in the installer?



Øyvind
Comment 7 kpalagin 2007-05-06 14:40:41 UTC
Closing as dup of http://qa.openoffice.org/issues/show_bug.cgi?id=70753.

*** This issue has been marked as a duplicate of 70753 ***
Comment 8 kpalagin 2007-05-06 14:42:58 UTC
and closing.