Issue 44223 - Installation terminates after selecting options
Summary: Installation terminates after selecting options
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2005-03-06 12:57 UTC by sommerer
Modified: 2013-08-07 15:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description sommerer 2005-03-06 12:57:03 UTC
Setup can be started. Options can be selected. When the installation process
shall start the window with the process bar comes up for a very short moment,
then another window pops up saying that the installation was cancelled.

OS: Windows XP Pro SP1 German
In the system event log this text can be found:
Ereignistyp: Informationen
Ereignisquelle: MsiInstaller
Ereigniskategorie: Keine
Ereigniskennung: 11708
Datum: 05.03.2005
Zeit: 15:36:05
Benutzer: Nicht zutreffend
Computer: WEZEL-WKS8929
Product: 1.9.79 -- Installation operation failed.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter

PC is used in an Active Directory Network. Alternative tries (Win2003 server on
a VirtualPC system, other Laptop with XP Pro German SP2) execute without any
problem from the same installation file source.

From the forum other users seem have to have the same problem. 
Installation on the same PC with an earlier version (1.9.69 ?) worked without

Also tried to get all OO entries out of the registry before new installation -
no change.
Comment 1 Olaf Felka 2005-03-07 09:13:24 UTC
For further investigations
Comment 2 sommerer 2005-03-10 19:16:28 UTC
Just found out the problem:

The download directory was explicitly owned by the current user. The group
"everyone" did not exist in the list of users for the installation source directory.

When I added "everyone" to the list of allowed groups the installer does its job
without hesitation. 

Maybe this should be an issue for the installer configuration as the installers
for some other programs worked in the same security environment without problems!

Comment 3 joerg.skottke 2005-03-14 13:57:32 UTC
jsk->cj: I have no idea whether this is your area of expertise but could you
please have a look or forward the issue to somebody who knows things?
This taks might be relevant for citrix installations.

Comment 4 flibby05 2005-04-21 13:49:05 UTC
set to NEW
Comment 5 christian.jansen 2005-05-19 16:19:19 UTC
CJ ->IS: I cannot do here anything. Ingo please have a look.
Comment 6 2005-05-24 13:26:51 UTC
Setting target
Comment 7 lsaffre 2005-07-08 07:54:47 UTC
I have the same phenomen on a Win XP home when trying to install
SRC680_m113_native_packed-1_en-US.8930. Currently I have no idea what may be the
cause. Any suggestions welcome.
Comment 8 2005-07-08 10:20:31 UTC
Hi lsaffre,

can you please try to approve the solution suggested by sommerer on March, 10th?
Do you still have this problem, after adding "everyone" to the owner of the
installation source directory?
Comment 9 lsaffre 2005-07-08 13:47:58 UTC
I don't use Active Directory Network, I am working on my local machine as
Adminstrator. So I think that I cannot try the solution suggested by sommerer.
But (tilt!) now I remember: I unpacked the installation directory to a virtual
drive L:, created using the SUBST command. That's it! This causes the problem! I
had the same problem with some other installer. Simply moving the directory from
L: to C:, then executing setup.exe from there, and it works! 

The problem should be reproducible on any XP machine:

1. Unpack the installation files to a directory

2. In a DOS box, type:

     subst l: c:\temp
     cd \SRC680_m113_native_packed-1_en-US.8930

   And the installer will give up after having asked installation options.

3. Launching the same setup.exe from the non-SUBSTed drive will work:

     cd \temp\SRC680_m113_native_packed-1_en-US.8930

Best regards,
Comment 10 2005-07-08 14:00:07 UTC
Luc, you can find some more information about this problem in #i36835.
Comment 11 2006-10-11 11:14:53 UTC