Issue 4485 - SUMPRODUCT function
Summary: SUMPRODUCT function
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: frank
QA Contact: issues@sc
URL:
Keywords:
: 24952 (view as issue list)
Depends on:
Blocks: 20494
  Show dependency tree
 
Reported: 2002-05-04 13:09 UTC by oblomov
Modified: 2013-08-07 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description oblomov 2002-05-04 13:09:54 UTC
The SUMPRODUCT function in Calc uses semicolons (;) to separate ranges. In Excel the same 
functions uses the asterisk (*). When converting from/to Excel, the cells containing 
SUMPRODUCT will give a #VALUE! error. Can SUMPRODUCT be changed to accept both syntaxes (and the 
converted be changed so that * is always used when saving in Excel format)?
Comment 1 oc 2002-05-17 10:32:41 UTC
Hi Daniel,
could you please have a look on this?
Comment 2 daniel.rentz 2002-05-21 07:07:00 UTC
In Excel you can use the parameter separators too ("," or ";").

Nevertheless this 
does not work in OOo, but this is a formula interpreter issue (Excel import works 
fine).
Comment 3 ooo 2002-05-21 10:44:54 UTC
Excel automatically assumes the parameter to be an array/matrix
parameter as if the formula was entered as an array formula (closed
with Shift-Ctrl-Enter), even if it wasn't. OOo doesn't perform this
automatic assumption but evaluates the parameter values as it usually
does, including position dependent range evaluation. OOo Calc will
produce the same results as Excel if the formula is entered as an
array/matrix formula.
Comment 4 oblomov 2002-05-21 14:02:34 UTC
The problem as it presented to me was like this: I imported some Excel sheets into 
Calc. While (almost) everything else was fine, all SUMPRODUCTs had a #VALUE! error; 
they had * as separators; as soon as I changed those to ; everything went ok.
Comment 5 ooo 2002-12-09 15:00:20 UTC
Target to OOo 2.0 (implement automatic parameter conversion for this
type of array formulas)
Comment 6 ooo 2003-11-06 21:17:10 UTC
Fixed on branch cws_srx645_cac.
Comment 7 ooo 2003-11-07 18:34:59 UTC
Reassign to QA.

Please find the specification at
http://specs.openoffice.org/calc/compatibility/cac/conditional_array_calculation.sxw
and see the parameter classification document listed under the
references section at the end of that document. Functions having
parameters of type ForceArray are affected by this new behavior.
Comment 8 frank 2003-11-13 12:01:39 UTC
reassigned
Comment 9 frank 2003-11-13 12:02:10 UTC
reset to fixed
Comment 10 frank 2003-11-13 12:02:44 UTC
now verified on cws cac on Linux, Solaris and Windows
Comment 11 frank 2003-11-13 12:03:14 UTC
verified I've said
Comment 12 daniel.rentz 2004-02-02 10:02:26 UTC
*** Issue 24952 has been marked as a duplicate of this issue. ***
Comment 13 frank 2004-03-16 14:02:30 UTC
found integrated on src680m30 using Linux, Solaris and Windows

Frank