Issue 44946 - Writer hangs while importing Word6.0/WinWord 95 file
Summary: Writer hangs while importing Word6.0/WinWord 95 file
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: 680m85
Hardware: PC Windows, all
: P3 Normal (vote)
Target Milestone: 4.1.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: crash, oooqa
Depends on:
Blocks:
 
Reported: 2005-03-13 17:56 UTC by gorgonz
Modified: 2017-05-20 10:33 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Word6.0/winword95 File (27.00 KB, application/msword)
2005-03-13 17:57 UTC, gorgonz
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description gorgonz 2005-03-13 17:56:12 UTC
version is V1.9.85 (german), win2000 SP4

to say this first: I think there a plenty of things beeing more important but
support for Word6.0/WinWord 95 file. Still I think, its not good, if the
application hangs. If we don't want to support that, then let us detect this
format and refuse it instead of the actual behaviour.

Now the situation: Opening this file from 1996, importing is done about 60%,
then writer hangs forever. Maybe its a good possibility for anlysis, since the
content just holds one page with header and footer. I will add the file.
Comment 1 gorgonz 2005-03-13 17:57:24 UTC
Created attachment 23768 [details]
Word6.0/winword95 File
Comment 2 flibby05 2005-03-13 19:38:31 UTC
confirm with m85 on SuSE 9.2
Comment 3 michael.ruess 2005-03-14 10:47:52 UTC
MRU->FLR: tested with 680m85, the import hangs at about 50% of progress with
this WW6 doc. OO 1.x had no probems.
Comment 4 andreas.martens 2005-03-14 11:26:16 UTC
If it's not fixed in time for OOo2.0, it should be fixed for OOo2.0.1.
Comment 5 andreas.martens 2005-05-25 14:53:56 UTC
Considering the effort, the priority, the risk and our resource planning I've to
retarget this issue to OOo Later.
Comment 6 gorgonz 2009-03-24 23:17:17 UTC
Just for info.

meanwhile i'm using linux (opensuese 11.1) and ooo300M15. The behaviour changed
in so far, that writer immediatelly crashes now.
Comment 7 Rob Weir 2013-07-30 02:41:36 UTC
Reset assignee on issues not touched by assignee in more than 1000 days.
Comment 8 Rainer Bielefeld 2013-12-11 05:11:08 UTC
(a) No longer reproducible with "AOO 4.0.1   – German UI / German locale  
   [Rev. 1524958 2013-09-20 11:40:29]" on  German WIN7 Home Premium (64bit)", 
   “historic”  4.0  User Profile used for all  predecessor versions

(b) Already ok with OOo 3.3.0

(c) But still crashed with 3.1.1 (for me not "only" hangs)

(d) Has been fixed for AOO 3.4.0, but because of crippled Target Milestone
   selector contents (Bug 123063) I only can select TM = 4.1.0, no correct
   information can be contributed.

(e) Trivial confirmed CRASH?
Comment 9 Rainer Bielefeld 2013-12-11 05:15:18 UTC
.
Comment 10 urmasd 2013-12-11 15:15:25 UTC
There still an issue with the table in footer, though.