Issue 45138 - Certain Japanese kanji are not displayed
Summary: Certain Japanese kanji are not displayed
Status: CLOSED DUPLICATE of issue 32939
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0 Beta
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: ulf.stroehler
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-16 03:43 UTC by azolotkov
Modified: 2005-03-16 14:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description azolotkov 2005-03-16 03:43:39 UTC
When typing a line in Japanese, certain kanji are not displayed. When I type
"watashi ha gakusei" 私は学生, kanji for "gaku", the third character from the
left, is ommited and a blank space takes its. When I select all, copy, and paste
into another application, the kanji is there. When I paste back into oowriter,
it is gone again. This used to happen in older version 1.1.2 as well. I use
kinput2+canna for my input, but the copy+paste observation suggests that input
doesn't matter. Changing fonts does not solve the problem. This happens to more
kanji than just "gaku" - if necessary I can try to find others.
Comment 1 michael.ruess 2005-03-16 06:53:58 UTC
Reassigned to US.
Comment 2 ulf.stroehler 2005-03-16 14:51:43 UTC
Looks fine at my side.

You should have set the Asian document language to "Japanese" at
"Tools/Options/Language Settings". Confirm with ok.

Again open "Tools/Options" go to "OpenOffice.org Writer/Basic Fonts (Asian)" and
hit the "Default" button.
Now the problem shouldn't show up in *new* Writer documents any more.

The above described procedure normally should happen automatically but doesn't
work due to issue 32939.

At my side the Sazanami fonts are chosen, but that depends on the fonts you
actually have installed.

*** This issue has been marked as a duplicate of 32939 ***
Comment 3 ulf.stroehler 2005-03-16 14:55:23 UTC
Closing dupe.